9 Replies Latest reply: Dec 14, 2012 8:19 AM by JesusPresley
cvakator Level 1 (0 points)



I found out a strange issue on my mac mini 2011 with Gigabit Ethernet port and what I see that it is works on automatic mode, in 100 mbit speed, but today I bought cisko 1 gbit switch and I still see in network utility 100 mbit. If I force the 1 gbit speed in seeting I will get error message like cable was unplugged.


Don't tell me that I have broken logic board. My varanty finished 2 months ago.


Thank you.

Mac mini (Mid 2011), Mac OS X (10.7.3)
  • BDAqua Level 10 (121,620 points)

    Hello, is everything else connected the the Gigabit Switch running at Gigabit speeds?

  • cvakator Level 1 (0 points)



    Yes, everything connected is 1 gbit speed. I am using this swith


    http://homestore.cisco.com/en-us/Switches/Linksys-SE2800-8-Port-Gigabit-Ethernet -Switch_stcVVproductId129966530VVviewprod.htm


    into the this swith is connected WD lifebook duo where is 1 gbit and BT Infinity internet router with 1 gbit port as well.


    Sometime I can connect by DHCP without any issues but only by 100 mbit. In other cases I have to connect by wifi but I preffer speed.

  • cvakator Level 1 (0 points)

    One more think. I was boot the windows via bootcamp and there is 100 mbit connection as well

  • John Galt Level 8 (44,615 points)

    You must also use either Category 5e or Category 6 Ethernet cables. If there are any connectors in between they must also be properly rated. Gigabit Ethernet is unforgiving of any deficiencies.


    Ensure System Preferences > Network is correct: Select Ethernet, Advanced, Hardware. Configure "Automatically".

  • cvakator Level 1 (0 points)

    Do you think the cable is problem? I don't think so - few years I used the cheap cat5 cable for company network and 1 gbit it was fine.


    The preferences are configurated on automatically. I can't force the speed to 1 gbit.



  • cvakator Level 1 (0 points)

    I have just ordered the cat5e cable, so I will see!

  • cvakator Level 1 (0 points)

    Ok, I have bought the Cat6e cable and now it's works great! But I am quite confused, because what I said above, in windows network few years it worked fine with cheap cable. Thanks for your help guys!

  • JesusPresley Level 1 (0 points)

    Yeah, but how do you know?


    Recently I replaced the 10/100 switch under my desk with gigabit switch. The next step is sitting here watching the Network control panel display the Ethernet connection; the Ethernet connection just keeps going up (green) and back down again (red) in an endless (approx) 3-5 second loop.


    As a practicing Linux admin, this looks like auto-negotiation is not working as it should. I've seen a lot of entries in this discussion about the brand and model of switch, this is (or should be) completely irrelevant. I say that knowing 1) auto-negotiation is standardized and therefore hardware agnositc, and 2) Manufacturing defects can happen within any product line.


    So, I called into the Apple Support line and my (MacBook Pro) Ethernet port was deemed bad. As a Linux admin I can only say that I was impressed with the support rep; The below steps are straight from Apple as troubleshooting techniques as of a few minutes ago. Sometimes the port is bad on the system, this is how you find out:


    1. Verify the cable is CAT5E or CAT6; as stated above, if you can't verify it then buy a new one. Open the Network control panel to see if the network connection continues going up and down.
    2. Swap Switch Ports; of course - first-day stuff. Leaving the cable plugged into the Mac, plug the other end of the cable into different ports on the switch. Open the Network control panel to see if the network connection continues going up and down. Assuming Step 1 is checked off the list, and Step 2 fails, there are still some options...
    3. Create a new TEST user;
      1. Open Users and Groups control panel

      2. Create a user called TEST (Admin account); no password is necessary.

      3. Click on your name (top-right by the system clock) and switch users.

      4. Open the Network control panel to see if the network connection continues going up and down.

        If you're good then you're good, if not, log out as this user and remove the TEST account.
    4. Reboot to the Startup Manager;
      1. Hold down the Option key during boot
      2. Select the restore disk, click the up arrow to enter the restore environment.
      3. There is no Dock or Network control panel but (in the top-right) you should now turn OFF your WiFi connection.
      4. Now, click on something (anything) that takes you online. If, for example the (online) support page does not load, the Ethernet port is still not working.
      5. Reboot.
    5. Move SystemConfiguration directory to the desktop; THIS WILL NOT HARM YOUR OS. Either:
      1. Navigate to this directory and cut+paste it to your desktop or,
      2. in the terminal:
        $ mv -f /Library/Preferences/SystemConfiguration/ ~/Desktop/
      3. Then reboot; when the Mac boots again it will see that these files are no-longer present and put a new directory in place of the missing one. All the files in the directory are new as well. This rules out preferences.
      4. Open the Network control panel to see if the network connection continues going up and down.
    6. Reboot in Safe Boot mode; This will load the OS with only necessary drivers and rule out any other system resources which may be conflicting with your Ethernet driver:
      1. Reboot and hold the Shift key down until you see a progress bar.
      2. Open the Network control panel to see if the network connection continues going up and down.



    If the behavior stops at any point you're in luck. If the Ethernet port continues going up and down then the port is cooked. These are your immediate options:


    1. Put the 10/100 Switch back in place. PITA but the cheapest solution.
    2. Start saving for a (logic board) repair, or
    3. Shell out for a new MacBook Pro.


    I hope this helps all that come after me.



  • JesusPresley Level 1 (0 points)

    OK ****! - was I wrong...


    After the above entry I packed up my MacBook, headed out to the Mac store and dropped it for repair; they had it overnight. "The Genius" called me to pick it up the next day. The answer:


    There's nothing wrong with your MacBook. They copied files back and fourth between my MacBook and many other hosts on their network; it performed as expected.


    I gave him a short history of the problem, and he said, "OOOOOooohhh, it's the Belkin." I brought my baby home, did a little research, found that others had a similar problem and found an acceptable fix. I ordered the new switches, a 5-port for my desk and an 8-port for the servers in the back room; incidentally, these items were inexpensive.


    I swapped out the Belkin F4G0500 for the TrendNet TEG-S50g and everything started popping:

    • The MacBook received (and retained) a DHCP lease
    • Files copied between the Mac and other hosts at gigabit speeds


    I should say the rest of my gear, 3 Linux Servers, a Linux Desktop/Laptop, and printer all made use of the Belkin at gigabit speeds (100MB file between Host A <--> Host B in 2 seconds), it was only the Mac that had trouble with the Belkins.


    I split this evenly between Belkin and Apple as a responsibility to fix for we the buyers. It's 2012, we should have layer 3 (switching) sorted out by now. This was minor but pricey pain in the ***.


    Troubleshooting Techniques:


    Create Files of a Specific Size

    You can use the "dd" (Unix) program to create files of a specific size. To test gigabit speeds, specific file sizes take the guessing out of the equation.

    1. Open the Terminal (Utilities directory)
    2. To create test files, enter both of the following lines (line one, then line two, giving each time to finish):
      1. dd if=/dev/zero of=~/Desktop/output_100MB.dat bs=1M count=100   # Creates a 100MB file
      2. dd if=/dev/zero of=~/Desktop/output_1GB.dat   bs=1M count=1000  # Creates a 1GB   file
    3. The files created in Step 3 will now be on your desktop ready for transfer/testing.
    4. Quit the Terminal.

    File Transfer Calculator

    This calculator will give you an approximation of what transfer times should be; at least it's close enough for me. There will be a little flux due to various (network) conditions, within 2-3 seconds it seems, but generally these estimations should hold.


    For my problem, I wanted to test a 100MB & 1GB file transfer between 2 computers (both with Gigabit Network Cards) on the same switch.

    EG: for the 2 files, I fill in the calculator:

    100MB file: Size: 100; Size Lable: MB; Speed Lable: -none ; Select Speed by interface: Wired Lan Gigabit Ethernet --> click Calculate = estimated 2 seconds.

    1GB file: Size: 1; Size Lable: GB; Speed Lable: -none ; Select Speed by interface: Wired Lan Gigabit Ethernet --> click Calculate = estimated 9 seconds.


    Verify Gigabit Speeds on the Switch

    The Trendnet ports will light up GREEN for each port that is functioning at gigabit (1000 Mbit/s) speeds; ports that are only running at Fast Ethernet speeds (100 Mbit/s) will light up AMBER. Transfers must occur between any 2 computers lit green on the switch.


    When I copy the files to another (host) computer I see transfer times for:

    • The 100MB file is on the money: 100MB   50.0MB/s  00:02 seconds.
    • The 1GB file takes a little longer: 1000MB  47.6MB/s  00:21


    Here we see approximately 50.0MB/s transfer times for both. The File Transfer Calc estimate was off by 12 seconds but I did notice that the transfer degraded slightly (in speed) the longer it persisted; even though that's true, the MB/s is similar.


    If you have a similar setup as me (1 switch under your desk, and 1 in the server room), repeat the transfers to (hosts) computers in the back room with a green light on the switch. The transfers should be similar if not the same. 


    It's not perfect but it's a week later and I'm almost $200 down; it's close enough for jazz and better than what I had before. I'm tired of screwing with it.


    Cheers all,