4 Replies Latest reply: Nov 8, 2012 7:08 AM by Ian R. Brown
Vitofromca Level 1 Level 1 (0 points)

does FCE works with mountain lion??


iMac, Mac OS X (10.7.5)
  • Alchroma Level 6 Level 6 (17,755 points)

    Yes but not supported by Apple.

     

    User experiences range from Cannot even install to minor glitches.

     

    It's pretty much put up with whatever you have or move to FCP X that Apple does support in Lion and Mountin Lion.

     

    Al

  • Ian R. Brown Level 6 Level 6 (18,395 points)

    A friend of mine bought a new iMac a few months ago and against my advice to move onto Final Cut Pro X he reinstalled his old FCE 4.

     

    He claims it works as good as ever!

     

    Of course he was using a brand new machine.

     

    If you have merely updated an old Mac to Lion, it may well be carrying a load of baggage that will cause problems with FCE.

     

    Message was edited by: Ian R. Brown

  • Vitofromca Level 1 Level 1 (0 points)

    here's my dilemma, originally the computer came with snow leopard " 10.6.8 " cleaned all up  replaced the defective HD, ( mac store genius bar did that ) and upgraded to lion " 10.7.5 " everything works fine ( so far ) including the FCE 4.0.1, , I was just wondering, because there are so many negative answers about it, ( including mac people) because is a third party software, they won't commit themselvs.

    Thanks for your comments anyway.

    Vito

  • Ian R. Brown Level 6 Level 6 (18,395 points)

    What do you mean by third party software?

     

    FCE 4 is Apple software.

     

    I have learned to ignore much that people say and test things for myself.

     

    If they work OK for me, that's great.