13 Replies Latest reply: Feb 27, 2013 5:59 PM by oskch308
itzmepraveenkumar Level 1 (0 points)

Process:         Safari [2737]

Path:            /Users/USER/*/Safari.app/Contents/MacOS/Safari

Identifier:      com.apple.Safari

Version:         5.1.7 (7534.57.7)

Build Info:      WebBrowser-7534057007000000~2

Code Type:       X86-64 (Native)

Parent Process:  launchd [123]



Date/Time:       2012-11-08 11:31:30.730 +0300

OS Version:      Mac OS X 10.7.5 (11G63)

Report Version:  9

Sleep/Wake UUID: 010FDC4D-5FD9-479E-9FEE-78C0A725F3C4



Interval Since Last Report:          65845 sec

Crashes Since Last Report:           16

Per-App Crashes Since Last Report:   10

Anonymous UUID:                      D2637DE2-34C8-43F6-8899-20FB919F4C41



Crashed Thread:  0




Exception Codes: 0x0000000000000002, 0x0000000000000000



Application Specific Information:

dyld: launch, loading dependent libraries



Dyld Error Message:

  Library not loaded: /System/Library/Frameworks/Accounts.framework/Versions/A/Accounts

  Referenced from: /System/Library/StagedFrameworks/Safari/Safari.framework/Safari

  Reason: image not found



Binary Images:

       0x10e2db000 -        0x10e2dbfff  com.apple.Safari (5.1.7 - 7534.57.7) <72510CA8-DEAF-3CA8-A9EC-C6FB872CE6E4> /Users/USER/*/Safari.app/Contents/MacOS/Safari

       0x10e2e3000 -        0x10e7d8fff  com.apple.Safari.framework (8536 - 8536.26.17) <A28655B2-8394-32D4-82C2-725FAD855E48> /System/Library/StagedFrameworks/Safari/Safari.framework/Safari

    0x7fff6dedb000 -     0x7fff6df0fbaf  dyld (195.6 - ???) <C58DAD8A-4B00-3676-8637-93D6FDE73147> /usr/lib/dyld

    0x7fff871a8000 -     0x7fff871d5fe7  libSystem.B.dylib (159.1.0 - compatibility 1.0.0) <6E5C8AC3-DBB7-31CB-BEB7-D6ED8E6DE0CE> /usr/lib/libSystem.B.dylib



Model: iMac12,1, BootROM IM121.0047.B1F, 4 processors, Intel Core i5, 2.5 GHz, 4 GB, SMC 1.71f22

Graphics: AMD Radeon HD 6750M, AMD Radeon HD 6750M, PCIe, 512 MB

Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x02FE, 0x45424A3230554638424353302D444A2D4620

Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x02FE, 0x45424A3230554638424353302D444A2D4620

AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x9A), Atheros 9380:

Bluetooth: Version 4.0.8f17, 2 service, 18 devices, 1 incoming serial ports

Network Service: Wi-Fi, AirPort, en1

Serial ATA Device: ST3500418AS, 500.11 GB

Serial ATA Device: HL-DT-STDVDRW  GA32N

USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x850b, 0xfa200000 / 3

USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2

USB Device: Cruzer Blade, 0x0781  (SanDisk Corporation), 0x5567, 0xfa130000 / 5

USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4

USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0xfa111000 / 8

USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2

USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfd110000 / 4

USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 3

iMac, Mac OS X (10.7.5)
  • itzmepraveenkumar Level 1 (0 points)

    I Resolved my issues by copying the Folder Safari from the below path of another lion os mac


    System>> Library >> StagedFrameworks >> Safari


    Do the following Steps..


    First open Terminal..


    Use the below cmd line:


    "open System/Library/StagedFrameworks/Safari/"


    Copy the Safari folder from another mac.


    Open the Mac terminal of your system


    use the same cmd line "open System/Library/StagedFrameworks/Safari/"


    Delete the files in the Safari Folder and paste the items copied from another mac.


    I hope the problem will solve.

  • ~Bee Level 7 (31,425 points)

    itzmepraveenkuar --


    Your problem actually is that your Safari application is in your USERS library.  It needs to be in Hard Drive > Applications folder.  Until it's in the right location, you will always have problems with it.  It will never update correctly, for starters.

  • Arman Sanati Level 1 (0 points)

    So where's the right location??

    How can we put safari to the right location??

  • ~Bee Level 7 (31,425 points)

    Double click on the Hard Drive icon (upper right of your screen), open up the Applications folder, and put your Safari in there.

  • itzmepraveenkumar Level 1 (0 points)

    No Bee.. When i checked the Apple software update its not showing the safari updates. So I downloaded the Mountain lion os safari plugin and installed. Because of that i got error that you can't run the safari in lion os. So i was fighting for restore.. Atlast.. I did the above and also successfully updated the version to latest safari also.

  • Arman Sanati Level 1 (0 points)

    It had it.

    I am currently reinstalling OS X lion.That might help!

  • Arman Sanati Level 1 (0 points)

    So you have OS X Lion?Can you upload your folder for me to use it , too?


  • itzmepraveenkumar Level 1 (0 points)

    Hi Arman,


    Did you reinstall the mac os.. If you reinstalled, then i hopefully will not get this error.. and one more thing.. I can share the folder of application pkg and the files in the path (System>> Library >> StagedFrameworks >> Safari) using dropbox.


    <Email Edited by Host>

  • ~Bee Level 7 (31,425 points)

    Arman (& itzme --)


    No, people here cannot legally give you their Operating System.  You must purchase it for yourself at the App Store.

  • Arman Sanati Level 1 (0 points)

    Hi all,


    Bee,I think you misunderstood.

    I had a problem with safari application and I just wanted his safari folder for fixing the problem if it could (as he said).I didn't want the OS because I have it since the time I purchased my MacBook Pro last week and I don't need it now and now my problem is fixed today,so I don't need the folder anymore.


    itzme,I had the same problem as you but I successfully passed it using Pacifist application.Try to install Safari 6 with this application and replace all of the files.Then you'll not get this error and you'll have safari in software update as I have.I just tried this today as my last try before reinstalling the OS X Lion and it was successful and I don't need your folder now,Thanks!Do this before reinstalling the OS because my error was the same as yours and I succeeded by using this.


    P.S. Oh,and I forgot!I'm currently writing this using safari 6 on my mac and I don't have this problem and I can update it (I updated today!) using the software update.

    And here's my discussion that was solved by me today : https://discussions.apple.com/thread/4674002?start=0&tstart=0




    Message was edited by: Arman Sanati

  • oskch308 Level 1 (0 points)


    By following:


    1) downloading Pacifist

    2) downloading Safari for Lion (safari6lion.pkg)

    3) Opening safari6lion.pkg in Pacifist

    4) deleting StagedFrameworks/Safari/ folder which can be found under: System/Library

    5) copy and paste StagedFrameworks/Safari/ from the opened safari6lion.pkg in Pacifist.


    Hope this helps others

  • tsehov Level 1 (0 points)

    Thank You very much, that did the trick with my MBP.

  • oskch308 Level 1 (0 points)

    Great to hear