Previous 1 2 3 Next 32 Replies Latest reply: Dec 13, 2012 1:55 AM by Michael Wüthrich Go to original post
  • michalmaria Level 1 Level 1 (0 points)

    Well this is so typical about Apple's server products. They probably wanted to release the new service with the entire OS X 10.8.2 update, but have pulled it in the last moment because it wasn't finished and we ended with this.

    I will install the update tomorrow and will report back.

  • Fred Turner Level 1 Level 1 (85 points)

    Dekamundo wrote:

     

    Looking promising !

     

    I have just updated Server to 2.2 and run update of iTunes 11 from 5 clients and all worked without reverting to the remote server.

     

    Obviously, a single update is too small a sample to break out the champagne, but it's a step in the right direction.

     

    I have not observed this problem to be specific to the server version, but rather the client version. At least, none of the server versions I've tried, including primarily a 10.6.8 SUS and 10.8.2 SUS, result in the the 10.8.2 (only!) clients being able to retrieve all of their updates from the SUS. That said, there could conceivably be some mechanism in 10.8.2 clients that is overlooking the SUS unless it has some fix specific to Server 2.2. I will check further, but suffice it to say so far that even on a machine running 10.8.(ahem)3 Server, its App Store was still reverting to Internet download for iTunes.

     

    Fred

  • Michael Wüthrich Level 1 Level 1 (5 points)

    The problem does not exist any more in my environment ... using the same clients (deployed by Software Update without any changes to the image deployed (e.g. 10.8.2 as before with existing problem) with the same server (10.8.2).

     

    The only update I made on the server was: I installed  iTunes (11.0 build 163).

     

    What else changed on my side?

     

    1. I played with naming

    Hostname:

    sudo scutil --set HostName xserve.mydomain.local

    ComputerName:

    sudo scutil --set ComputerName xserve.mydomain.local

    LocalHostName:

    sudo scutil --set LocalHostName xserve

     

    2. I changed some rules on my firewall - none affecting the problem described here (to my knowledge).

     

    I have no explanation what solved the problem, but it works now!

Previous 1 2 3 Next