10 Replies Latest reply: Nov 12, 2012 3:04 PM by Aye Es Oh
tomematthews Level 1 (0 points)



I've just updated my Aperture to 3.4.2 on a Macbook 13inch 2009 running OSX 10.8.2


It told me I needed to upgrade my library to work with the new version, then quit half way through the process. I'm now getting an error every time I start Aperture saying that I need to repair my library.


When I click repair, it goes most of the way through (sometimes right up to 99%) and then quits, and when I restart, the whole process starts again...


Any help would be appreciated!



Aperture 3, OS X Mountain Lion (10.8.2)
  • Aye Es Oh Level 2 (330 points)

    Any better results with a rebuild of your database? Hold down the "Command" and "Option" keys when starting up Aperture to reveal this option.

  • tomematthews Level 1 (0 points)

    Hi Aye Es Oh!


    Thanks very much for your help! Sadly, that made no difference

  • léonie Level 10 (90,876 points)

    , it goes most of the way through (sometimes right up to 99%) and then quits,

    Quits? Do you get a crash log? Then post the first 50 lines of the crash report.

  • tomematthews Level 1 (0 points)

    Hi LeonieDF


    Hope this is enough (let me know if you need more!)






    Process:         Aperture [816]

    Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

    Identifier:      com.apple.Aperture

    Version:         3.4.2 (3.4.2)

    Build Info:      Aperture-310019000000000~2

    App Item ID:     408981426

    App External ID: 10581304

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [166]

    User ID:         501



    Date/Time:       2012-11-10 20:05:57.069 +0000

    OS Version:      Mac OS X 10.8.2 (12C60)

    Report Version:  10



    Interval Since Last Report:          6271 sec

    Crashes Since Last Report:           9

    Per-App Interval Since Last Report:  1283 sec

    Per-App Crashes Since Last Report:   9

    Anonymous UUID:                      72F230F4-C55C-257A-AF82-355F0495DFF6



    Crashed Thread:  14  Dispatch queue: com.apple.root.default-priority



    Exception Type:  EXC_CRASH (SIGABRT)

    Exception Codes: 0x0000000000000000, 0x0000000000000000



    Application Specific Information:

    *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSURL initWithScheme:host:path:]: path 504537562 is not absolute.'

    terminate called throwing an exception

    abort() called

  • léonie Level 10 (90,876 points)

    Somewhere in the crashlog must be a part:

    Thread 14 -...

    Please post the complete thread 14 as well ...

  • tomematthews Level 1 (0 points)

    Hi Leonie


    Is this what you need?


    Thread 14:: com.apple.appkit-heartbeat

    0   libsystem_kernel.dylib                  0x00007fff98fc1386 __semwait_signal + 10

    1   libsystem_c.dylib                       0x00007fff8f6e5800 nanosleep + 163

    2   libsystem_c.dylib                       0x00007fff8f6e5717 usleep + 54

    3   com.apple.AppKit                        0x00007fff914b9958 -[NSUIHeartBeat _heartBeatThread:] + 543

    4   com.apple.Foundation                    0x00007fff8d1c0612 __NSThread__main__ + 1345

    5   libsystem_c.dylib                       0x00007fff8f65b742 _pthread_start + 327

    6   libsystem_c.dylib                       0x00007fff8f648181 thread_start + 13




  • léonie Level 10 (90,876 points)

    That thread 14 must be from a different crash log, the names of the threads do not match, but never mind.


    The first part you posted looks suspiciously like the problem many posters had, when Aperture 3.4. first has been released. Did you upgrade to Aperture 3.4. from an early Aperture 3 version?

    Then you need to reinstall from your original installation media, see:

    Aperture 3.4: May quit unexpectedly on launch after updating

  • tomematthews Level 1 (0 points)

    Hi Leonie - Thank you SO much - this worked!! Wonder what happened?! Anyway, thank you so much for your help (and thanks also to Aye Es Oh!)

  • léonie Level 10 (90,876 points)

    You are welcome. I am glad it worked for you.


    My suspicion is, that you upgraded from an Aperture version that uses an incompatible "Account Configuration Plug-in", and when Aperture tries to set up Facebook account data, Aperture crashes. Reinstalling from an earlier version or completely new installs the correct plug-in, a similar crash is here:


    Version 3.4.2 aperture wont open just crashes, Version 3.4.2 aperture wont open just crashes





    @ Aye Es Oh  : This is probably another case like the one you mentioned in your earlier post! It is still going on. I hoped the 3.4.2 release would fix this.

  • Aye Es Oh Level 2 (330 points)

    Yes, strange that it's got a different message, and that it happened at 99%. Hopefully the new update fixes it if it happens to someone else.