6 Replies Latest reply: Sep 18, 2013 2:42 PM by ianlarsen
robertk1 Level 1 Level 1 (0 points)

I've searched all over the place and can't find any solution to this problem, so I'm asking here in the hope that someone else has encountered it.

 

The problem:   Netflix is choppy to the point of being unusable if the computer is busy.  But it's not because of the computer (see below).  It appears to be I/O related.

 

Things I've tried: 

  1. Different browsers.  Firefox, Safari, and Chrome all have the same problem.
  2. I've reinstalled Silverlight several times.  It doesn't help.
  3. I've rebooted, logged out and back in, logged in as a different user, and so forth.  It doesn't matter.
  4. Changing the quality setting on Netflix doesn't matter.  I've tried on every setting from the highest to the lowest, and it doesn't matter.
  5. Watching full screen or windowed doesn't make any difference.  I can resize the window as small as possible, the problem still exists.
  6. I've doubled the amount of memory in the machine.  It didn't help.  The computer is an 8-core Mac Pro (2008), with 16 GB of memory and NVidia 8800GT graphics.
  7. I've tried enabling and disabling hardware acceleration.  It doesn't seem to matter.
  8. All other audio/video applications (including iTunes) play perfectly, whether playing a local file or streaming.  It is only Netflix / Silverlight that has the problem.

 

I believe it to be triggered by I/O, because if the machine isn't very busy, I can watch Netflix just fine.  Large file copies or DVD reads will cause the problem.  I might normally think this is just a machine limitation, but with 8 cores and 16 GB of memory, I really don't think that's the problem.   I really think it is a Silverlight / Netflix problem. 

 

And here's the real kicker.  Under the same load that causes Netflix to be unwatchable, I can fire up a virtual machine running Windows (thereby *increasing* system load), run a copy of Google in the virtual machine, and Netflix will play perfectly in it.   So I really don't think it's a problem with the machine's capabilities.

 

Is there any kind of setting I can check, or a preference that I can change to resolve the problem?  I hate to have a whole virtual machine running just to run Netflix when I already have a native player available. 


Mac Pro, OS X Mountain Lion (10.8.2)
  • Andrew0002 Level 1 Level 1 (0 points)

    I have the same problem on my mid 2011 27" iMac with a quad core 3.4GHz i7 with 16GB of DDR3 ram. Ever since I upgraded to Mountain Lion, Netflix stutters. I also have the same results with a virtual machine. I can watch Netflix in a Windows XP vm, or a Windows 8 vm, with no stuttering. It doesn't matter if Safari or Firefox is the only program running.

  • robertk1 Level 1 Level 1 (0 points)

    It has been a week -- no solution or workaround has been suggested, and a handful of other people are having the same problem.  Andrew has verified my experience and assumption that it is not a machine capability problem. 

     

    Is there no solution?  Are we doomed to running a Windows VM just to watch Netflix?  Even though I found no solution when searching the web, I found plenty of people having this problem.  Have any of the three parties involved (Apple, Microsoft, and Netflix) expressed any concern?

  • Andrew0002 Level 1 Level 1 (0 points)

    There seems to be little to no stuttering for me now, but I'm not sure what changed. I cleared the Sliverlight application storage for Netflix, and that seems to be the last thing I did before it stopped stuttering, but I cannot confirm that nothing else changed on my computer. Here's what I did:

     

    Open up a movie or tv show on netflix, and control click or right click anywhere in the window and click Silverlight Preferences.

     

    Screen Shot 2012-11-23 at 6.49.40 PM.png

     

    Go to the Application Storage tab and delete the application storage for Netflix. For good measure you might want to log out and log back in to make sure that Sliverlight doesn't keep anything cached. Just a heads up: after doing this the volume for the Netflix player will go back to 100%. 

     

    Screen Shot 2012-11-23 at 6.50.01 PM.png

  • robertk1 Level 1 Level 1 (0 points)

    Thanks, Andrew.  I tried doing that, but it didn't work for me.  It's still choppy. 

  • MagnusVonMagnum Level 1 Level 1 (5 points)

    I get choppy video if I use Firefox on a 2012 Mac Mini with 10.8.2, but it's smooth (most of the time) if I use Safari.  It's definitely NOT the load as it was using only 6% on Firefox.  The plugin uses 85% in Safari but it's smooth (less than one core,  though).  The one thing I do like is that I can put Netflix on my 2nd monitor in full screen and still use my primary monitor for doing other things (unlike Apple's own full screen crap which makes the other monitor useless most of the time).  I'm actually able to play Scrabble on pogo.com, transmit 720P webcam over skype to another player and watch HD movies with no real ill effect.  I don't know why Firefox is choppy, though.  Firefox uses nearly 100% to play Scrabble on Pogo.com too while Safari only uses like 3% plus the Java usage (16% which is the same for both).  Why would Firefox need so much CPU power when Java is doing nearly ALL the work?  I like Firefox better for browsing, but clearly it ***** at some tasks online at least in OSX.

  • ianlarsen Level 1 Level 1 (0 points)

    This won't be any help for the many who have tried various browsers along with so many other possible solutions, but for what it's worth I can say that using Safari instead of Firefox seems to have brought Netfix back to normal for me.

     

    This is after I went from 2GB to 4GB RAM, did a complete clean reinstall of the whole Macbook, reset the SMC, and ran a complete Hardware Test that raised no faults on the fan, battery, processor or anything.

     

    This a mid-2009 white Macbook with Mountain Lion. So hopefully I can carry on now, we'll see.