11 Replies Latest reply: Dec 29, 2012 9:01 AM by DSL_Steve
Level 1 (45 points)

I can not update my Apple TV2 to the latest update.


The update downloads for a bit then stops and I get the "Cannot update---.try again later" message.


I've had the Apple TV2 for 1.5 years and have always been able to update. Currently running 5.0.2.


Been trying for months now. Any suggestions aside from changing router/Apple TV DNS addresses (already tried those) is appreciated.


Even tried the micro USB/iTunes resort but it only comes up as a restore in iTunes---no Update option.

  • Brian Cook4 Level 4 (1,960 points)

    STOP!!!!!!  Read though the list it caused a lot of problems for people.  You do NOT want that update.  It has no new features.  It just causes new bugs.

  • Level 1 (45 points)

    Bump for the weekend,

  • Level 1 (45 points)

    I am having the same problem as my original post with the 5.1.1 update (and yes, I am using wireless)..

  • Level 1 (45 points)



    Over wireless, still cannot update (now its to 5.1.1). It starts to dwnload then stops 3 or 4 mins into the download.

  • Winston Churchill Level 10 (95,839 points)

    If your problem persists get yourself a micro USB cable (sold separately), you can restore your Apple TV from iTunes:

        1.    Remove ALL cables from Apple TV. (if you don't you will not see Apple TV in the iTunes Source list)

        2.    Connect the micro USB cable to the Apple TV and to your computer.

        3.    Reconnect the power cable (only for Apple TV 3)

        4.    Open iTunes.

        5.    Select your Apple TV in the Source list, and then click Restore.

  • Level 1 (45 points)

    If the iTunes interface is bogus, then I can I understand. I don't want to RESTORE, I want to UPDATE.


    Why can't I update without jumping through hoops (disconnect cables, connect special cable, run iTunes etc.)?

  • Winston Churchill Level 10 (95,839 points)

    If you have an issue updating and you aren't willing to disconnect it and undertake some basic troubleshooting steps then I can't help you further.

  • Level 1 (45 points)

    No offense intended, but its easy to see from all the "can't update" threads, Apple has a problem with this product and it's software.


    I could care less about updating, just trying to make a point (in this forum) with Apple.


    Thanks for the input though. If I ever want to update again, I'll try your recommendation.

  • Winston Churchill Level 10 (95,839 points)

    Yes I know there was an issue updating with v5 software for a small number of users, which is why I'm providing you the solution. You need to restore from iTunes as explained, some have still had issues doing this, in which case there are some further procedures to follow.

  • Level 1 (45 points)

    Updated to 5.1.1 using the micro USB cable method. A so-called clean install.


    Now Netflix only streams for 30 seconds then stops. It sometimes dumps me back to the Netflix movie menu, then sometimes times out with an error.


    Netflix streaming works great on all other devices on my network (two laptops, three iPhones, two iPads and a Samsung TV).


    Another bonus of 5.1.1 is Photo Stream no longer works.

  • Level 1 (45 points)

    Fixed my Photo Stream issue by setting up a Shared Photo Stream holder/item on my iPhone for all the pictures I want to use as a screen saver on the Apple TV2.