Previous 1 2 Next 17 Replies Latest reply: Jan 21, 2013 1:21 PM by bayxsonic
felix47 Level 1 (0 points)

Using iMac 27" 3.4 GHz Intel Core i7.


Since I have upgrade to Mountain Lion 10.8.2 and iPhoto 9.4.1 and 9.4.2, using menu «Reveal in Finder» (original or modified photo) doesn't work anymore.


This menu was working fine beforehand.


Could it be related with the last upgraded version of Java (version 7, upgrade 9) ?


Thanks for your advices.

  • Terence Devlin Level 10 (137,910 points)

    What happens when you try?

  • felix47 Level 1 (0 points)

    Absolutely nothing 

  • Terence Devlin Level 10 (137,910 points)

    Create a new account (systempreferences -> accounts or Users & Groups on 10.7 and 10.8), make a new Library in that account, import some shots  and see if the problem is repeated there.






  • felix47 Level 1 (0 points)

    Creating a new account gigaave me the same result : nothing happens. 

  • Terence Devlin Level 10 (137,910 points)

    To re-install iPhoto


    1. Put the in the trash (Drag it from your Applications Folder to the trash)


    2a: On 10.5:  Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.


    2b: On 10.6: Those receipts may be found as follows:  In the Finder use the Go menu and select Go To Folder. In the resulting window type




    2c: on 10.7 they're at




    A Finder Window will open at that location and you can remove the iPhoto pkg files.


    3. Re-install.


    If you purchased an iLife Disk, then iPhoto is on it.


    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.


    If you purchased it on the App Store or have a Recent Mac you can find it in your Purchases List.

  • felix47 Level 1 (0 points)

    It doesn't make any difference.


    Still can't go back to the place where is a photo.


    Creating a new library doesn't help.

  • Old Toad Level 10 (135,388 points)

    Make a temporary, backup copy (if you don't already have a backup copy) of the library and try the following:


    1 - delete the iPhoto preference file,, that resides in your

         User/Home/Library/ Preferences folder.


    2 - delete iPhoto's cache file, Cache.db, that is located in your

         User/Home/Library/Caches/ folder. 



    Click to view full size


    3 - launch iPhoto and try again.


    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.


    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.



  • felix47 Level 1 (0 points)

    Still no luck.


    I, even, have try to use an iPhoto Library six months old (Time Machine) with no more success.


    Could it be related to a Framework ?

  • Old Toad Level 10 (135,388 points)

    Possibly.  It's beginning to look like a system issue.  Try reapplying the OS X Mountain Lion Update v10.8.2 (Combo)  and repair disk permissions afterward. 

  • felix47 Level 1 (0 points)

    Already done it... Without success

  • felix47 Level 1 (0 points)

    Finally find where the problem comes from : always using OS X 10.8.2, it's upgrading from iPhoto 9.3.2 to 9.4.0.


    But I can't know why...

  • Old Toad Level 10 (135,388 points)

    Where did you get iPhoto 9 in the first place?  From the App Store, came installed on your Mac or purchased the iLife 11 disc?

  • felix47 Level 1 (0 points)

    I get iPhoto 9 from the iLife 11 disc and the different upgrades from Apple site.


  • Old Toad Level 10 (135,388 points)

    Have you tried reinstalling iPhoto from the iLife 11 disc and the upgrade thru the Apple Downloads webpage to whatever version works best for you?


    If you do try a reinstall  you'll have to delete the current application and all files with "iPhoto" in the file name with either a .PKG or .BOM extension that reside in the:


    HD/Library/Receipts folder (10.5 and earlier)


    or from the /var/db/receipts/  folder (10.6) .




    or from the /private/var/db/receipts folder (10.7 or later)


    Then install iPhoto from the source it came from originally and apply the updaters.

Previous 1 2 Next