3 Replies Latest reply: Nov 14, 2012 12:04 PM by bernieciPhoto
bernieciPhoto Level 1 (0 points)

Am on verison 9.4.2 (710.42) of iLife 11.  Never had a problem in printing before.  However, when I now try to print a photo I get the following error box that appears:


No Avaialable Themes

There were no themes located.  Until at least one

theme has been installed, this feature ill be



Needless to say - there's no advice in Help to tell me how to access or install themes from this 'print using my own printer ' dialogue - and no very apparent \theme' selections process except when ordering prints.



MacBook Pro (17-inch Early 2008), Mac OS X (10.7.5)
  • Terence Devlin Level 10 (136,565 points)




    To re-install iPhoto


    1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)


    2a: On 10.5:  Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.


    2b: On 10.6: Those receipts may be found as follows:  In the Finder use the Go menu and select Go To Folder. In the resulting window type




    2c: on 10.7 they're at




    A Finder Window will open at that location and you can remove the iPhoto pkg files.


    3. Re-install.


    If you purchased an iLife Disk, then iPhoto is on it.


    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.


    If you purchased it on the App Store or have a Recent Mac you can find it in your Purchases List.

  • Old Toad Level 10 (133,235 points)

    There's another way you might be able to restore the themes. 


    1 - download the iPhoto 9.4.2 updater from the Apple Downloads webpage.

    2 - download and launch the demo version of   Pacifist.

    3 - drop the 9.4.2 update package into the open Pacifist window.

    4 - select the iPhoto folder and have Pacifist intall it.

    Screen Shot 2012-11-11 at 9.11.57 AM.jpg


    5 - repair disk permissions with Disk Utility.

    6 - launch iPhoto and try printing again.



  • bernieciPhoto Level 1 (0 points)

    Thanks for this.  It worked - but needed the addition of some useful advice from a colleague. You must re-install in the Admin account and NOT in the user account where all your favourite photos are.  Since you will be  downloading an older version of iPhoto it will attempt to open your 'current version' library and either will refuse to open or may even screw the library database up!.  By re-installing in the Admin account it means that all updates can be done there to get it back to 'current' from the original iLife disc version BEFORE attempting to open up your current library.  Doing that - the re-install worked perectly when applied to the photo library in my user account.  Thanks again.