2 Replies Latest reply: Nov 11, 2012 10:11 AM by Kappy
gadgetgrl3 Level 1 Level 1 (0 points)

I am running OS X 10.6 on an iMac. I want to update to 10.7 (Lion) so I can use iCloud. Lion is not in the APP store and I can't find a way to download it. I chatted with Apple and they lead me to a download for 10.7.5 but it requires 10.7. Help!


iMac, Mac OS X (10.6.8)