8 Replies Latest reply: Nov 18, 2012 5:31 AM by cjexpat
cjexpat Level 1 Level 1

Hi everyone


I recently had a hard drive crash on my "vintage" 2006 intel iMac. Got the HD replaced but the support service I used was unable to retrieve any of my data off it. Luckily I had all files backed up in a cloud service.


The support service reloaded Snow Leopard onto my new HD but using their own disks, not mine.


I've downloaded my iPhoto Library folder with all photos etc from my backup service and have tried to simply drop it into my Pictures folder to get back everything I had: photos, albums, photo metadata (I'm thinking Ratings in particular).


However when I open iPhoto I'm getting the message "You can’t open your current photo library using this version of iPhoto. You have made changes to your photos using a newer version of iPhoto. Please quit and use the latest version of iPhoto"


I'd appreciate any expert help before I continue. Does this suggest that the support service have loaded an older version of iPhoto than the one I previously had, or could it be the case that they in fact loaded a newer one?


What's my best course of action to fix this? I'm guessing that I could reload Snow Leopard from my own disks without running a disk erase and get back to the version of  iPhoto that I used to edit these photos before the crash - does that make sense?


I am not at all technically literate and well appreciate I may be overlooking or misunderstanding something.


Any help greatly appreciated



Solved by Terence Devlin on Nov 14, 2012 3:43 PM Solved
That's what I would do...
  • Terence Devlin Level 10 Level 10

    This doesn't have anything to do with Snow Leopard. This has to do with iPhoto. What versions you had and what you have now. So, have you run software update?

  • cjexpat Level 1 Level 1

    Terence - thanks for the quick response. Yes, I ran software update immediately after the new HD was in place to restore a few drivers etc. Just tried it again - no updates found at this point in time.


    The reason I associated the iPhoto version with Snow Leopard is (a) when I upgraded to SL the disk set came with an iLife upgrade as well (which I didn't implement) and (b) when the support service guys restored SL on my new HD they reinstalled all the iLife suite as well.


    Now, the "You can’t open your current photo library using this version of iPhoto" error message that I'm getting when I fire up iPhoto prevents the app from opening (only option from the error message is to Quit) , so I can't get to see the "About" info that would tell me what version it is .... that said, I don't know what version I was running previously!


    Any suggestions as to next best step really appreciated - thanks in advance

  • Terence Devlin Level 10 Level 10

    You can see the version in the Finder, in column view:


    Screen Shot 2012-06-15 at 22.25.54.png

  • cjexpat Level 1 Level 1

    Right ! Thanks - so, I'm on version 6.06 which I'm guessing is pretty old.


    Is thsi just a question of upgrading to the latest version,or at least the most recent version that I have here at home on discs (on the basis that this would have been the most recent version I may have used to edit the photos I have)?


    Sorry if I'm being very slow and stupid . The point us,I don't want to pay for an upgrade when I had a perfectly adequate version previously, althoiugh, as I say, I don't know exectly what version it was ....

  • Terence Devlin Level 10 Level 10

    6.0.6 is the latest version of iPhoto 6.


    And no, unless you had iPhoto 08 or some later version already, upgrading will not fix the problem. It's a bogus message. If you did not open the Library with iPhoto 08 or later then the Library is corrupt.


    Try these in order - from best option on down...


    1. Do you have an up-to-date back up? If so, try copy the library6.iphoto file from the back up to the iPhoto Library allowing it to overwrite the damaged file.


    2. Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)


    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.



    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. 


    3. If neither of these work then you'll need to create and populate a new library.


    To create and populate a new *iPhoto 6* library:


    Note this will give you a working library with the same Rolls and pictures as before, however, you will lose your albums, keywords, modified versions, books, calendars etc.


    Move the iPhoto Library to the desktop


    Launch iPhoto. It will ask if you wish to create a new Library. Say Yes.


    Go into the iPhoto Library on your desktop and find the Originals folder. From the Originals folder drag the individual Roll Folders to the iPhoto Window and it will recreate them in the new library.


    When you're sure all is well you can delete the iPhoto Library on your desktop.


    In the future, in addition to your usual back up routine, you might like to make a copy of the library6.iPhoto file whenever you have made changes to the library as protection against database corruption.

  • cjexpat Level 1 Level 1



    Sorry about taking a few days to reply -- work getting in the way of the rest of life !


    Really appreciate the detailed feedback.


    I tried step 1 by copying the library6.iphoto file from the backup into the iPhoto library as you described. iPhoto then opened OK but went through a long routine of "restoring thumbnail cache"


    With this finished I can now open iPhoto but the thumbnail view of a lot of my photos is not appearing (just getting greyed out frame where the photo thumbnail should be) and I can't open these photos in full view either.


    Should I just move to your step 2 to try and overcome this?


    Thanks so much !!

  • Terence Devlin Level 10 Level 10

    That's what I would do...

  • cjexpat Level 1 Level 1

    OK tried the iPhoto Library Manager route but no luck ... it was unable to restore a large number of the photos so I just removed the duplicate library and went to step 3, which looks like it has worked fine ... just means I have to recreate all the albums etc but hey ho !


    Anyway thanks again for all the help Devlin, much appreciated