4 Replies Latest reply: Nov 13, 2012 4:10 AM by vinnyvg
gadgetgurl42 Level 2 (175 points)



I'm trying to add hyperlinks in my text to act as cross-references. I can add a bookmark as the target, but when I highlight the text elsewhere to act as the link  and go Insert > Hyperlink none of the 4 options are available. They'll all greyed out.


In the Link Inspector, the check box to enable hyperlinks is also disabled. The only thing I can click here is the checkbox saying Make all hyperlinks inactive.


I originally tried link from the text on a section layout (depending on the template, sometimes set as Objectives - definitely not H1 or H2) to a place in a page. Then I tried linking from Heading 1 text on a page to body text elsewhere. Neither option worked.


Is this a bug in iBooks Author 2.0?

iBooks Author 2.0, OS X Mountain Lion (10.8.2)
  • vinnyvg Level 4 (1,865 points)

    I am not sure what your problem is.. but as  nobody has profered any suggestions.

    I  just opened a text box - wrote link test, selected.- Insert> (  the four options offered - I selected Bookmark and  it opened the inspector  showing bookmark.   The  text link  was underlined and blue!

    I repeated  using any word on the page... no problems.


    In the inspector I selected Bookmark and went to the Book column right of screen - clicked on  a page and in the  inspector clicked the +  and it inserted  " Bookmark" and  the page number I had selected.


    First  time I tried this!!  now I have to find a use for it!

  • K T Level 7 (23,700 points)

    What Vinny failed to say was that your issue seems atypical.


    You may want to reinstall iBA, and if still no joy, contact Apple/iBA support for clarity.

  • K T Level 7 (23,700 points)

    Vinny - are you suggesting the OP isn't using the tool right or that you've not seen the same, or?

  • vinnyvg Level 4 (1,865 points)

    My post shows what I did to create a text link  using the  Insert > Hyperlink > Bookmark option.


    gadgetgurl42 said he could not make an active link. I had no trouble. So to anwser your question.. I did not see what he saw!  Which was a greyed out set of insert options.


    I did not say he was doinbg anything wrong, I simply  tried to do what he wanted ... and then explained how I did it.


    While  my post shows its possible , if he /she  cannot do it then your post about a re install is sound advice.