6 Replies Latest reply: Jan 4, 2013 1:49 PM by JimTN
PokemonFan1987 Level 2 (185 points)

Adobe Acrobat NPAPI Plug-in, Version 11.0.0

Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.0 — from file “AdobePDFViewerNPAPI.plugin”.
application/pdfAcrobat Portable Document Formatpdf
application/vnd.adobe.pdfAcrobat Portable Document Format (Interim)pdf
application/vnd.adobe.pdfxmlAcrobat XML Portable Document Formatpdfxml
application/vnd.adobe.x-marsAcrobat XML Portable Document Format (Interim)mars
application/vnd.adobe.xdp+xmlXML Data Packagexdp
application/vnd.adobe.xfd+xmlFormFlow99 Data Filexfd
application/vnd.adobe.xfdfAcrobat Forms Data Format in XMLxfdf
application/vnd.fdfAcrobat Forms Data Formatfdf
  • etresoft Level 7 (27,858 points)

    Delete it from ~/Library/Internet Plug-ins or /Library/Internet Plug-ins

  • JimTN Level 1 (0 points)

    If only this worked.  Although the plugin shows in installed plugins in Safari help, the file is not present in Internet Plugins or anywhere else, although a search in spotlight yields a reference to it in Terminal:


    Last login: Fri Jan  4 12:44:26 on ttys000

    Jamess-iMac:AdobePDFViewerNPAPI.plugin Quinn$


    I am reluctant to attempt addressing anything in Terminal, but it appears there remains a line of code somewhere that still attempts to invoke the offending plugin.  This is more than a minor problem, because it prevents me from reading .pdf files in Safari.  Many sites don't offer a download option.


    I'm open to any and all ideas.

  • Eric Root Level 9 (50,657 points)

    Have you tried going to Safari/Preferenes/Extentions and doing what is below?


    From Safari Help:


    To see if any settings are available for an extension, select the extension in the extensions list. Any available settings appear in the box on the right.

    To uninstall an extension, click its Uninstall button.

  • gumsie Level 4 (2,155 points)

    Hi Jim, you did notice that Etresoft actually gave two different locations to look in right?


    Do you have any Prefpanes that relate to it also?

  • VikingOSX Level 6 (15,883 points)

    I see a couple of things. You apparently have several Adobe Acrobat Pro browser plug-ins installed. If any of these are not compatible with Mountain Lion, or Safari, they too can be problematic in normal Safari operation.


    Adobe Reader 11.0 (in my case) installs two files into /Library/Internet Plug-Ins:


    1. AdobePDFViewer.plugin
    2. AdobePDFViewerNPAPI.plugin


    And in the same location, Safari would otherwise use:

    1. Quartz Composer.webplugin


    The Adobe Reader 11.0 plug-ins will take priority over the default Quartz Composer web plugin. This is my preference as it offers extended PDF handling.


    If you remove both Reader items 1 and 2, then if there are no other Adobe Acrobat plugin conflicts, Safari should resort back to using the Quartz Composer PDF plug-in.


    In the Finder sidebar, under DEVICES, the top item should be a small disk drive with your hostname next to it. Double-click that item. Now you have another hard drive symbol that bears the name of the partition you installed OS X on. It might be Macintosh HD. Double-click this icon. Now, double-click Library, and then Internet Plug-Ins.


    Select both AdobePDFViewer plugin files. Now, right-button click and move them to the Trash. Since these are system files, you will be prompted for your login password to complete the removal. Empty the Trash.


    The next time you run Acrobat Reader 11.0, it will re-install these two PDF plugins. Adobe Acrobat Pro may restore these plug-ins too.


    Hope that helps.

  • JimTN Level 1 (0 points)

    Thanks to all for the quick replies.  I fixed it by eventually finding the file but it is still somewhat of a mystery. Both locations listed only two plugins in the Internet Plugins directory, but I have more plugins than that including that infernal Adobe bomb.  So I did another search in both libraries, this time listing the .plugin file extension, and found them all - Including two copies of the Adobe file(s).  I deleted them both and everything is fine.  Adobe viewer had been uninstalled, never to return.


    Here's the mystery:  When searching for the entire AdobePDFViewerNPAPI.plugin filename in Finder or Spotlight, nothing came up.  So, for others unable to find the file, I suggest you extend your search to the entire computer and search for the .plugin extension and sort through the results.  I have no idea why, but it seems the file can pop up anywhere.


    Again, thanks for the responses!