12 Replies Latest reply: Nov 22, 2012 6:17 AM by Linc Davis
corvino26 Level 1 (0 points)

I have a MacBook Pro Mid 2009 2.66 GHz Intel Core 2 Duo with 8gb of memory. Computer ran excellent for all these years from snow leopard to lion but once i upgraded to mountain lion it tends to reboot and or restart on almost every start up. Any suggestions would be greatly appreciated.


Thanks in advance!

MacBook Pro, OS X Mountain Lion (10.8.2), Unibody
  • Linc Davis Level 10 (192,265 points)

    What exactly do you see when this happens?

  • corvino26 Level 1 (0 points)

    It doesnt show anything it will just restart and then show a white screen with grey lettering saying your computer has been restarted. It will automatically restart in 30 seconds or press any key. Then I will press a key and it will restart and work fine.

  • corvino26 Level 1 (0 points)

    Thank you for your quick response and help. I have just tried this out and hopefully it will work out. My girlfriend reminded me that I did have something else pop up once a while back but it has not came up in a while. this is what it showed. Not sure if this can be resolved by the same troubleshooting.



  • Linc Davis Level 10 (192,265 points)

    That was a kernel panic, but it happened months ago.

  • corvino26 Level 1 (0 points)

    After several restarts it seems my macbook pro no longer has that problem will update again in a couple of days... major thanks for the help!

  • corvino26 Level 1 (0 points)

    Its doing it again! I have no idea what the heck is going on now... Same white screen with grey lettering. When the computer restarts it says that my computer restarted for a reason. I will try and get a screen shot of the report next time it does it. Any more ideas or troubleshooting would be greatly appreciated.

  • Linc Davis Level 10 (192,265 points)

    Launch the Console application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.


    Select the most recent panic log under System Diagnostic Reports. Post the entire contents — the text, please, not a screenshot. In the interest of privacy, I suggest you edit out the “Anonymous UUID,” a long string of letters, numbers, and dashes in the header and body of the report, if it’s present (it may not be.) Please don't post shutdownStall, spin, or hang reports.

  • corvino26 Level 1 (0 points)

    I just realized I posted a screenshot of one of these messages earlier in the thread... here is the most recent one. Thank you for the quick response... hope we can get this problem solved... I use this for work... I might try to re-install mountain lion.



    Wed Nov 21 10:37:19 2012

    panic(cpu 0 caller 0xffffff8004ea27aa): "pmap_pv_remove(0xffffff80176d7c00, 0x10e0cd000, 0x2c0ce, 0x800000002c0ce066, 0xffffff80ec1d3cf4, 0xfffffe82255c6668): pv not on hash, head: 0xffffff80176d7c00, 0x10e0cd000"@/SourceCache/xnu/xnu-2050.18.24/osfmk/i386/pmap_internal.h:826

    Backtrace (CPU 0), Frame : Return Address

    0xffffff80ec1d3bf0 : 0xffffff8004e1d626

    0xffffff80ec1d3c60 : 0xffffff8004ea27aa

    0xffffff80ec1d3d20 : 0xffffff8004ea2b65

    0xffffff80ec1d3d70 : 0xffffff8004e66a1c

    0xffffff80ec1d3e60 : 0xffffff8004e6a8f0

    0xffffff80ec1d3e90 : 0xffffff8004e35a53

    0xffffff80ec1d3ed0 : 0xffffff8005156607

    0xffffff80ec1d3f40 : 0xffffff80051563a9

    0xffffff80ec1d3f50 : 0xffffff80051e182a

    0xffffff80ec1d3fb0 : 0xffffff8004eced33



    BSD process name corresponding to current thread: distnoted



    Mac OS version:




    Kernel version:

    Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64

    Kernel UUID: xxxxxxxxxxxxxxxxxxxxxxx

    Kernel slide:     0x0000000004c00000

    Kernel text base: 0xffffff8004e00000

    System model name: MacBookPro5,3 (Mac-F22587C8)



    System uptime in nanoseconds: 965787876525

    last loaded kext at 22036011570: com.apple.driver.AppleHWSensor          1.9.5d0 (addr 0xffffff7f86d3d000, size 36864)

    last unloaded kext at 147072301262: com.apple.driver.AppleFileSystemDriver          3.0.1 (addr 0xffffff7f86f94000, size 8192)

    loaded kexts:

    com.apple.driver.AppleHWSensor          1.9.5d0

    com.apple.iokit.IOBluetoothSerialManager          4.0.9f33

    com.apple.driver.AudioAUUC          1.60

    com.apple.driver.AGPM          100.12.69

    com.apple.driver.AppleMikeyHIDDriver          122

    com.apple.filesystems.autofs          3.0

    com.apple.driver.AppleHDA          2.3.1f2

    com.apple.driver.AppleMikeyDriver          2.3.1f2

    com.apple.iokit.BroadcomBluetoothHCIControllerUSBTransport          4.0.9f33

    com.apple.driver.AppleSMCLMU          2.0.2d0

    com.apple.iokit.IOUserEthernet          1.0.0d1

    com.apple.Dont_Steal_Mac_OS_X          7.0.0

    com.apple.driver.ApplePolicyControl          3.2.11

    com.apple.driver.ACPI_SMC_PlatformPlugin          1.0.0

    com.apple.driver.AppleUpstreamUserClient          3.5.10

    com.apple.driver.AppleLPC          1.6.0

    com.apple.driver.AppleMuxControl          3.2.11

    com.apple.driver.AppleMCCSControl          1.0.33

    com.apple.GeForce          8.0.0

    com.apple.driver.SMCMotionSensor          3.0.2d6

    com.apple.driver.AppleUSBTCButtons          235.4

    com.apple.driver.AppleUSBTCKeyboard          235.4

    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless          1.0.0d1

    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib          1.0.0d1

    com.apple.BootCache          34

    com.apple.driver.AppleIRController          320.15

    com.apple.driver.AppleUSBCardReader          3.1.0

    com.apple.iokit.SCSITaskUserClient          3.5.1

    com.apple.driver.XsanFilter          404

    com.apple.iokit.IOAHCIBlockStorage          2.2.2

    com.apple.driver.AirPort.Brcm4331          602.15.22

    com.apple.driver.AppleFWOHCI          4.9.6

    com.apple.driver.AppleUSBHub          5.2.5

    com.apple.driver.AppleAHCIPort          2.4.1

    com.apple.driver.AppleSmartBatteryManager          161.0.0

    com.apple.nvenet          2.0.19

    com.apple.driver.AppleUSBOHCI          5.2.5

    com.apple.driver.AppleUSBEHCI          5.4.0

    com.apple.driver.AppleEFINVRAM          1.6.1

    com.apple.driver.AppleRTC          1.5

    com.apple.driver.AppleHPET          1.7

    com.apple.driver.AppleACPIButtons          1.6

    com.apple.driver.AppleSMBIOS          1.9

    com.apple.driver.AppleACPIEC          1.6

    com.apple.driver.AppleAPIC          1.6

    com.apple.driver.AppleIntelCPUPowerManagementClient          196.0.0

    com.apple.nke.applicationfirewall          4.0.39

    com.apple.security.quarantine          2

    com.apple.driver.AppleIntelCPUPowerManagement          196.0.0

    com.apple.iokit.IOSerialFamily          10.0.6

    com.apple.kext.triggers          1.0

    com.apple.driver.DspFuncLib          2.3.1f2

    com.apple.iokit.IOAudioFamily          1.8.9fc10

    com.apple.kext.OSvKernDSPLib          1.6

    com.apple.iokit.AppleBluetoothHCIControllerUSBTransport          4.0.9f33

    com.apple.iokit.IOFireWireIP          2.2.5

    com.apple.driver.AppleHDAController          2.3.1f2

    com.apple.iokit.IOHDAFamily          2.3.1f2

    com.apple.iokit.IOSurface          86.0.3

    com.apple.iokit.IOBluetoothFamily          4.0.9f33

    com.apple.driver.IOPlatformPluginLegacy          1.0.0

    com.apple.driver.AppleSMBusPCI          1.0.10d0

    com.apple.driver.IOPlatformPluginFamily          5.2.0d16

    com.apple.driver.AppleGraphicsControl          3.2.11

    com.apple.driver.AppleBacklightExpert          1.0.4

    com.apple.driver.AppleSMBusController          1.0.10d0

    com.apple.nvidia.nv50hal          8.0.0

    com.apple.NVDAResman          8.0.0

    com.apple.iokit.IONDRVSupport          2.3.5

    com.apple.iokit.IOGraphicsFamily          2.3.5

    com.apple.driver.AppleSMC          3.1.4d2

    com.apple.driver.AppleUSBMultitouch          235.7

    com.apple.iokit.IOUSBHIDDriver          5.2.5

    com.apple.iokit.IOSCSIBlockCommandsDevice          3.5.1

    com.apple.iokit.IOUSBMassStorageClass          3.5.0

    com.apple.driver.AppleUSBMergeNub          5.2.5

    com.apple.driver.AppleUSBComposite          5.2.5

    com.apple.iokit.IOSCSIMultimediaCommandsDevice          3.5.1

    com.apple.iokit.IOBDStorageFamily          1.7

    com.apple.iokit.IODVDStorageFamily          1.7.1

    com.apple.iokit.IOCDStorageFamily          1.7.1

    com.apple.iokit.IOAHCISerialATAPI          2.5.0

    com.apple.iokit.IOSCSIArchitectureModelFamily          3.5.1

    com.apple.iokit.IO80211Family          500.15

    com.apple.iokit.IOFireWireFamily          4.5.5

    com.apple.iokit.IOUSBUserClient          5.2.5

    com.apple.iokit.IOAHCIFamily          2.2.1

    com.apple.iokit.IONetworkingFamily          3.0

    com.apple.iokit.IOUSBFamily          5.4.0

    com.apple.driver.NVSMU          2.2.9

    com.apple.driver.AppleEFIRuntime          1.6.1

    com.apple.iokit.IOHIDFamily          1.8.0

    com.apple.iokit.IOSMBusFamily          1.1

    com.apple.security.sandbox          220

    com.apple.kext.AppleMatch          1.0.0d1

    com.apple.security.TMSafetyNet          7

    com.apple.driver.DiskImages          344

    com.apple.iokit.IOStorageFamily          1.8

    com.apple.driver.AppleKeyStore          28.21

    com.apple.driver.AppleACPIPlatform          1.6

    com.apple.iokit.IOPCIFamily          2.7.2

    com.apple.iokit.IOACPIFamily          1.4

    com.apple.kec.corecrypto          1.0

  • Linc Davis Level 10 (192,265 points)

    That panic was not caused by third-party software. If the problem is recurrent, the possibilities are (1) a damaged OS X installation; (2) a fault in a peripheral device, if any; (3) an internal hardware fault; and (4) an obscure bug in OS X.


    You can rule out the first two possibilities by reinstalling the OS and testing with non-essential peripherals disconnected. Probably there will be no change. In that case, make a "Genius" appointment at an Apple Store to have the machine tested. You may have to leave it there for several days. There isn't much point in doing this unless you can reproduce the panic, or unless it happens often enough that it's likely to be repeated at the store. Otherwise you may be told that nothing is wrong.


    Print the first page of the panic report and bring it with you.


    Back up all data on the internal drive(s) before you hand over your computer to anyone. If privacy is a concern, erase the data partition(s) with the option to write zeros* (do this only if you know how to restore, and you have at least  two independent backups.) Don’t erase the recovery partition, if present.


    *An SSD doesn't need to be zeroed.

  • corvino26 Level 1 (0 points)

    could this have to do with a hard drive i just installed on my macbook pro? I put the hard drive in an enclosure formatted it to mac osx journaled and installed mountain lion from a recovery drive i have. The install seemed to be fine and I installed the new hard drive. This issue started happening after I installed the new hard drive.

  • Linc Davis Level 10 (192,265 points)

    Could be.