Previous 1 2 3 4 Next 48 Replies Latest reply: Apr 3, 2014 11:55 PM by peterSunquest Go to original post
  • joeholmes Level 1 Level 1 (0 points)

    Contents of the Aperture Library package:

     

    Aperture.aplib/

    ApertureData.xml

    Attachments/

    Database/

    iLifeShared/

    iPod Photo Cache/

    Masks/

    Masters/

    Previews/

    Thumbnails/

     

    The Finder says it's Kind: Aperture Library

  • joeholmes Level 1 Level 1 (0 points)

    Thanks for the suggestions.

     

    I can successfully create a new, empty library.

     

    But my original library is 2.2 TB, so I can't easily find space to import, and in any case that will take hours and hours, so it's not an easy experiment to conduct.

     

    Also, I'd hate to lose all my original organization.

  • joeholmes Level 1 Level 1 (0 points)

    Oh, and on someone's suggestion earlier, I had deleted the info.plist file that was in the library's package. That's why that file isn't listed in the package contents.

  • joeholmes Level 1 Level 1 (0 points)

    I've tried deleting the Aperture preferences, to no avail.

     

    At this point I'm going to try to reinstall the application.

  • léonie Level 9 Level 9 (63,955 points)

    The Library file looks o.k.

    have you logged off, before deleting the Aperture preferences? In Mt. Lion you cannot be sure, that the running Aperture process is not cached and revived, otherwise. I'd reboot, before trying again.

     

    You can try to reinstall Aperture, but I really suspect, the problem is with the Aperture library. If you can manage to import the old Aperture linrary into a new on - Import as library, not as folder, then all your projects, albums, keywords, etc. should be imported as well.  But you would need to find an empty drive with plenty of space to be able to try that.

     

    We could use Frank Caggiano's input here, if he had time to come back to this thread

  • joeholmes Level 1 Level 1 (0 points)

    Thanks, @leonieDF -- I don't have a HD large enough to import, so for right now that's not an option.

  • Frank Caggiano Level 7 Level 7 (25,695 points)

    I'm at a bit of a loss here. What the OP is seeing is making a lot of sense.

     

    One thing I would be interested in seeing is if the OP was to start Aperture while holding down the option key to get the library choice window up. And then post a screen shot of the window.

     

    regards

  • joeholmes Level 1 Level 1 (0 points)

    Screen Shot 2012-11-13 at 5.35.15 PM.png

     

    The original view in this window no longer appears -- it originallyalso showed my Aperture Library HD with the "Aperture Library.aplibrary" file. I selected that and hit "Choose" but got the error I've been describing.

  • joeholmes Level 1 Level 1 (0 points)

    This is getting a little scary:

     

    One more datapoint -- I created a new library on a freshly erased 3TB drive, told Aperture to create a new library on it, and told it to import my original Aperture Library (the one that's been giving me problems).

     

    I get the same error -- it asks me to update the library using iPhoto.

     

    So now seven years' worth of images in my Aperture Library appear to be inaccessible through any method (other than, I suppose, reimporting all the master copies of the images from the Masters folder inside the Aperture Library package).

  • léonie Level 9 Level 9 (63,955 points)

    If you copy your most recent backup to the empty 3TB drive, can you open that copy in Aperture?

  • Frank Caggiano Level 7 Level 7 (25,695 points)

    I can understand your concern but hang in there.

     

    Looking back at the thread I can;t find any mention of your Hardware or OS versions or how this problem materialized.

     

    So lets start there. What is your hardware configuration? You said that this library is 2.2 TB but the screen shot you posted above shows the library on the internal drive so how is this possible? How many externa;l drives do you have and how are thye formated? It is important thatthe Aperture library be on a OS X formatted dick.

     

    What OS version are you running? It looks like Aperture is 3.4.3. When did you upgrade?

     

    How did the problem start? You said this is a library you have been using for a long time what else was going on when the problem started?

     

    Finally what version of iPhoto do you have?

     

    regards

  • joeholmes Level 1 Level 1 (0 points)

    I tried opening my most recent backup vault in Aperture as if it were a normal Aperture Library, but Aperture only offers to restore my library, not open the backup vault as a regular library.

     

    I seem to remember that Aperture used to be able to open a standard Aperture backup vault as a library. Did that change??

  • joeholmes Level 1 Level 1 (0 points)

    I'm running an Early-2008 Mac Pro with 14 GB RAM and OS 10.8.2 (Mountain Lion).

     

    I've got Aperture 3.4.3. An hour or two ago, I dragged the App to the trash and reinstalled from my original Disk, then updated using the Apples files online, back to 3.4.3 (which didn't help).

     

    I update Aperture whenever an update is offered, so if I remember, that was a couple weeks ago. Aperture and my library were running normally as recently as yesterday. (I keep the library on separate internal 3TB HD in one of the internal bays in my Mac Pro).

     

    The problem arose this afternoon when I launched Aperture. It threw up a dialog telling me that I needed to use iPhoto to update the file.

     

    Finally, I don't own iPhoto, and there's no copy of it on my HD. I used to have a copy, but I couldn't tell you how long ago that was. It was probably months ago if not longer.

  • léonie Level 9 Level 9 (63,955 points)

    But did you ever use iPhoto, or import an iPhoto Library into your Aperture Library?

  • joeholmes Level 1 Level 1 (0 points)

    But did you ever use iPhoto, or import an iPhoto Library into your Aperture Library?

     

    Not that I remember. If I did, it was probably a year ago or more.