Previous 1 2 Next 15 Replies Latest reply: Nov 13, 2012 6:17 PM by Anon M
Anon M Level 1 (0 points)

I know that the bleeping means there is an issue. I recently just bought 32 GB of RAM and now filled all 4 slots.


However my computer still started and I'm writing here now, the "About this Mac" menu also says "32 GB" for the memory.


The Mac had kind of "restarted" somehow without the bleeping. Not really restarted, but it opened a new loading window (all white with the mac logo I think) and then it showed me the login screen.


I first had some problems installing it. I watched exactly in which direction and on which side the current RAM came out, to put the new RAM in the correct way as well. But when I tried this, it failed, and I just found a picture here which shows why:


You see that little slot on the top of both of them, but on the blue one it's on the left and on the green one it's more on the right?


Well that was exactly my problem, the RAM I bought (they guaranteed me it would work with my iMac) has this little slot on the other side.


I first tried pushing it and I saw in many tutorial videos that people were saying "Don't be afraid to push too hard, it needs to click" but I found this very strange, so I stopped and compared it to my old RAM until I noticed this little slot.


So I just turned it around and that's how I installed it.



I'm wondering, is this the problem? Because I put it in the "wrong" way? The thing is, I can't put it inside another way... only like this...


BTW, I don't think I've damaged it.

iMac, OS X Mountain Lion (10.8.2)
  • Anon M Level 1 (0 points)

    Little correction: Actually it was bleeping and I was holding the turn off button at the back, (because what else should I do?) and then instead of turning off it opene the new blank window and loaded the login screen.


    BUT I've just restarted it and there was no bleeping or whatsoever, it started pretty fast, so I guess the RAM works, no? I think everything should be fine, or does it always bleep only once / the first time?


    Thanks guys, hope I don't have to change it out or anything.



    Edit: I'm not sure but I think the RAM doesn't work properly... I'm trying to record a game and it doesn't really work, the recording is extremely... "slow", it has like 1 frame per 5 seconds haha. I think with 32 GB of RAM this shouldn't be an issue? It's running at highest quality on the normal iMac resolution (2560 x 1440)

  • Paul_31 Level 6 (13,655 points)

    Where did you get the RAM? There have been quite a few threads on here where users have had problems with certain makes of RAM, although most of the issues seem to be related to using 16gb.

    The two places that get recommended consistently as providing reliable RAM that works - and with a lifetime guarantee - are and


    Here's a long thread on the subject:

  • Anon M Level 1 (0 points)

    Thanks, I got the RAM at!


    My Mac however does not shut itself down without warning, but I'm going to read this thread further!


    Logic by the way works fine, I have very heavy projects and that's why I bought the RAM in the first place. Also with the bridge, in 64 bit mode, I feel that I have lots of memory to my disposition.


    I'm just sad that the video game recording doesn't work properly, is maybe some of the RAM damaged? Is there a way to check this? Because I find it strange that the recording has so few frames, when it was recorded with 32 GB of RAM, that should be enough I think. The game and the recording app are both in 32 bit mode, is that the reason maybe? That would be 4 GB for each, I thought that'd be enough.

  • babowa Level 7 (29,960 points)

    Also, if you have a total of four slots for your RAM, you need to match the RAM sticks horizontally, similar to this (screenshot of mine):


    Screen Shot 2012-11-13 at 8.32.24 AM.png

    And, as mentioned, quality does matter, i.e. Kingston Value Brand does not have a good track record here, but OWC ( and Crucial do.

  • Anon M Level 1 (0 points)

    Thanks for your answer, but what do you mean with horizontally? I can't see your screen unfortunately, could you upload it again please? That would be cool.


    That could be the reason maybe!


    And yes I made sure to buy from Crucial, I've heard OWC and Crucial are the best and since I'm in Europe I had free shipping from Crucial (plus it was a bit cheaper).

  • babowa Level 7 (29,960 points)

    Well, you said you filled all 4 slots, so presumably you put in 4 x 8 GB? Then you should be fine as far as matching. Not sure why you can't see the image I added to my post - it's not my screen, it's a pic (screenshot) of the system showing my memory slots and how they are populated.

  • Anon M Level 1 (0 points)

    Exactly I have 4 x 8 GB.


    Strangely enough, I still can't see it and when I right-click it and try to open it in a new tab, it tells me:



    An general error occurred while processing your request.



    Anyway, I'm still wondering about my RAM, if something wrong with it or not. Perhaps I damaged it while I was trying to get it in, remember I first had it the wrong way round. This is all very very strange tbh.



    Edit: Um, shouldn't it be "A general error", without the N? Even more strange now haha. Or is that because it's "An error"? Ok nevermind...

  • Paul_31 Level 6 (13,655 points)

    Are you sure you put it in the wrong way round to start with. There's a notch in one edge of the board to help avoid that .

    You could drop down to 16gb to see if that helps resolve the problems, maybe testing the modules in separate pairs to try to eliminate any duff ones.

    I see you got them from Crucial - did you note what make they are?

  • Anon M Level 1 (0 points)

    When saying notch, do you mean that little kind of "slot" at the top of them, like in the picture I posted in my first post?


    Because what I did basically was to take out the RAM that was already in there, and I put it on the table exactly as it came out – to know in what way to put the new RAM in.


    So I tried that and forced a bit, but it didn't work. I took it out and compared it the the MAC RAM. I noticed the notch you were talking about was on the downside, so I put it inside the other way. Basically I just looked on which side the writings were, and not on which side the notch was. Only later I noticed the notch.

  • Paul_31 Level 6 (13,655 points)

    The 'notch' is a gap in the metallic edge. The shorter metallic section is on the right as you push the RAM in with the Mac face down. I've got a late 2009 27" and it's clearly shown on page 40 of the Everything Mac booklet that came with the computer.

    It can take some shoving to get it to seat properly.

  • Anon M Level 1 (0 points)

    Yeah that's what I thought the notch is. See, the problem is that I first inserted them with the notch on the wrong side. I didn't pay attention to the notch, I only paid attention on which side the writings were. So I forced it and the little metal or whatever, that should get into the notch, probably damaged the metallic edge where there is no nodge. I think I damaged it


    Made some pics, they're below!


    However I just took the RAM out, placed it differently (in different slots I mean), everything worked fine, Mac started normally, no bleep or whatsoever.


    I opened iPhoto to get those pics I made of the RAM, iPhoto is super fast and loads very quickly. Before that it usually wasn't the case, it always needed ages to load.


    But since 2 of them are maybe "damaged", maybe I only have 16 GB right now. Even if my Mac says 32 everywhere.


    What do you think?





  • Paul_31 Level 6 (13,655 points)

    If the Mac is now performing well you might have got away with it.

    You could launch Activity Monitor in Utilities, click on the System Memory tab and try to do some work that'll really need a lot of RAM - should be able to see how much is being accessed/used.

  • Anon M Level 1 (0 points)

    Ok I went there and yeah it says 32 GB total, right now not even 28 are free, 1 and a half are reserved, 2 are active (not sure why, I only use Mail, Safari and Activity Monitor right now...) and 500 MB are inactive. A total of 4 GB that are used.


    What's that mean? Is something wrong with it do you believe? It seems to use a lot of RAM for nothing. 4 GB, that's what I had before.

  • Paul_31 Level 6 (13,655 points)

    Sounds normal to me. I've got 12gb of RAM and have Mail, Chrome & Skype running, and this is my usage:


    Screen Shot 2012-11-13 at 21.23.01.jpg

    Maybe just use the Mac and see if it runs as you would hope. It's only going to access the 32gb of RAM when it needs to - perhaps when processing large video files whilst doing lots of other things as well.

    Keep Activity Monitor open and launch numerous applications and just watch to see if you start to max out the RAM. If you see RAM usage anything in the 24-30+gb that should show it's all being utilised and so long as nothing goes pop I think you're OK.

Previous 1 2 Next