9 Replies Latest reply: Nov 14, 2012 5:18 PM by teri4m
teri4m Level 1 (0 points)

IIMG_0628.JPGIMG_0629.JPG


iPhoto '08, OS X Mountain Lion (10.8.2), iphoto '09 after updates
  • Old Toad Level 10 (135,551 points)

    Try this:  launch iPhoto with the Option key held down and create a new, test library.  Import some photos and check to see if the same problem persists. If it does try this basic troubleshooting fix:  make a temporary, backup copy (if you don't already have a backup copy) of the library and try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

         User/Home/Library/Caches/com.apple.iPhoto folder. 

     

    home.PNG

    Click to view full size

     

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

     

    OT

  • teri4m Level 1 (0 points)

    Thanks for your prompt reply.  I tried both your recommendations but unfortunately neither one worked.  Apparently, the problem arises when I try to launch the music browser when making/editing a slideshow.  Everytime I hit the music icon or tab, it just hangs and will have to force quit iPhoto.

  • Old Toad Level 10 (135,551 points)

    Download and reapply the following updaters:

     

    OS X Mountain Lion Update v10.8.2 (Combo)

     

    OS X Mountain Lion 10.8.2 Supplemental Update

     

    iPhoto 8.1.2

     

    Then repair disk permissions and reboot. See if that helps.

  • teri4m Level 1 (0 points)

    I really appreciate your taking time to help me with this issue.  I did the updates and repaired disk permissions.  Still not working.  I was thinking of just giving in and upgrading to iPhoto '11 but I'm afraid the problem might persist even after the upgrade.

  • Old Toad Level 10 (135,551 points)

    Upgrading to iPhoto 11 won't fix the library.  Before you try that do the following: make a temporary, backup copy of your library if you don't already have one (Control-click on the library and select Duplicate from the contextual menu) and  apply the two fixes below in order as needed:

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

    iPhotorebuild.PNG

     

    Select the options identified in the screenshot

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.
      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option
      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

  • Old Toad Level 10 (135,551 points)

    One more try:

     

    Starting over from scratch with new library

     

    Start over with a new library and import the Originals (iPhoto 09 and earlier) or the Masters (iPhoto 11) folder from your original library as follows:

     

    1. Open the library package like this.

     

    open.PNG

     

     

    2. Launch iPhoto with the Option key held down and, when asked, select the option to create a new library.

     

    3. Drag the Originals (iPhoto 09 and earlier) or the Masters (iPhoto 11) folder from the open iPhoto Library package into the open iPhoto window.

     

    iPhotolibcontents.PNG

     

     

    This will create a new library with the same Events (but not necessarily the same Event names) as the original library but will not keep the metadata, albums, books slideshows and other projects.

     

    Note:  your current library will be left untouched for further attempts at a fix if so desired.

  • teri4m Level 1 (0 points)

    Did all your recommendations but still unsuccessful.  I think whatever the problem is, it's not in the library.  It's whatever links iphoto to my music files that is messed up.  Everything else in iphoto works except the fact that it does not allow me to add/change music to slideshows.

  • Old Toad Level 10 (135,551 points)

    One more attempt:  delete the com.apple.iPhoto.plist and com.apple.iApps.plist preference files and the iPhoto cahce file that's in the Home/Library/Caches/com.apple.iPhoto folder.  Then open iTunes followed by iPhoto.

  • teri4m Level 1 (0 points)

    Finally!!!   It's working!  Woohoo!  So, I guess the problem was in the iApps.plist because that's the only one I haven't touched or deleted before.  Thanks a million times, Old Toad!