12 Replies Latest reply: Nov 20, 2012 11:29 AM by bigbreak
bigbreak Level 1 (0 points)

After the update to iPhoto 9.4 all albums are incomplete, so are the photo books (created from the albums...) I tried to restore the photo book data from time machine, but it did not work. They showed for two seconds in iPhoto in the photo book - then they vanished picture by picture. Seems to me as if iPhoto created randomly only parts of the albums after the update, some are almost complete, others are almost empty. So the photo book is not able to create the informations it needs to show the pictures. It's all there on time machine, but i'm not able to restore it or iphoto wont have restored it... Pretty weird, anyone whit the same problem here - and the solution...?


Thanks, Marco from Switzerland

iPhoto '11, OS X Mountain Lion (10.8.2)
  • Old Toad Level 10 (135,351 points)

    What do you mean by album?  The albums in the left hand pane of iPhoto or books? By incomplete do you mean many of the thumbnails are missing entirely and you have fewer thumbnails in the album or some of the frames are empty in the book pages? 


    Can you describe in more detail?



  • bigbreak Level 1 (0 points)

    Yes, the albums in the left hand pane. The Albums are still there, but the thumbnails are missing. One album lost all pics, others only few.


    Because I createt the books whit the pictures from the albums, I guess that the book is not able to get the Informations from the albums since they are gone.


    The structure, layout and all text from the book is still there, just the pictures are partly gone.


    All originals are there and iPhoto is working normaly.

  • Old Toad Level 10 (135,351 points)

    Are the pictures still in their Events or missing from the library entirely?

  • bigbreak Level 1 (0 points)

    ...sorry, was on the road...


    The pictures are in their Events, they are just partly missing in the albums.

  • Old Toad Level 10 (135,351 points)

    I think you'll just have to repopulate the albums and books and continue on unless you have a backup copy of your iPhoto Library from before the update that you can restore.

  • bigbreak Level 1 (0 points)

    How do I repopulate the albums and books?  I have a backup copy on TM, and I found in the project cache of the backup the entire albums. I tried to restore the file "project cache" whit TM. Then I opened iPhoto again, opened the book and the book was complete. It worked for a couple of secondes, then all the pictures vanished one by one and it was as before. Probably I have to restore the album as well, because the book take the photo informations from the albums. So, how can I restore the album?


    If possible, I would avoid to restore the entire Library, it would take hours (40GB..)



  • Old Toad Level 10 (135,351 points)

    You have to restore the entire iPhoto Library to get the albums and books back.




    If the first restored library loses photos then delete it, go back in time in TM and resotore another version.  Be sure to select Keep Both when you restore so you keep your current library which may have photos the restored library doesn't.


  • bigbreak Level 1 (0 points)

    Okay, will do that. Thanks a lot for your instant and precise help over the ocean.. ;-) I am going to report after restoring the Library if it worked well.

  • bigbreak Level 1 (0 points)

    Okay, I did the update and checked the content of the Library before I opening it with iPhoto. All books were in the file project cache. Then I opened the Library and iPhoto destroyed my books again. Same picture. As if the new version is not compatible with the old books or albums.


    Can I download the former version from iPhoto. It's impossible to recreate the books, it would take weeks.

  • Old Toad Level 10 (135,351 points)

    The only files that are in the ProjectCache folder are thumbnails for the book's pages.  The rest of the book is an entry(s) in the database file. 


    If you can restore the library w/book from Time Machine before you updated iPhoto you could install the earlier version of iPhoto also with Time Machine and give it a try.

  • bigbreak Level 1 (0 points)

    Huh! I reinstalled iPhoto 9.1.2, but it didn't opened and asked for the newer Version to run under OSX 10.8.2. So there I'm, back to start... but it was worth to give it a try. Right now I,m loading iPhoto 9.4.2 and then I try it again with the intact Library from TM. It's hard to understand why the change from iPhoto 9.1.2 to 9.4.2 should destroy the albums and the books?!

  • bigbreak Level 1 (0 points)

    I finally found the problem and fixed it... The same time I upgradet to iPhoto 9.4.2, I divided one very big Library into three separate Librarys. I did tis with the iPhoto Library Manager, which is a helpfull tool, but it seems that in this case the programm destroyed the fotobook informations when it divided the Library.


    Fortunately I still had an old version of my Library on TM and saved everything to a external drive. From there iPhoto 9.4.2 was able to read the Library - and to show my books! Huh, it took a while, but now I got it.


    Sorry, but I totaly missed to mention the divided Librarys, I'm sure you would have solved the problem faster then I did with this info...


    Thanks a lot for helping, you did a great job!!