5 Replies Latest reply: May 6, 2013 12:04 PM by slmccormick
Wildb0yz Level 1 (0 points)

I am having NAT problems when connecting to Xbox Live. My current setup is a 5th generation Airport Extreme router with firmware version 7.6.1 and Motorola SB-6121 modem. My ISP is Comcast. I have a wired connection to my Xbox however I have this same problem if I use a wireless connection. I can connect to Xbox Live with no problems however my NAT type is changing between Open which is preferred and Moderate. It is a tossup each time I turn the system on which NAT type I will get. I have had several discussions with Senior Techs at Apple but we have had no luck in solving the problem. I have tried forwarding the ports recommended by Xbox, setting up a static ip and making the Xbox the default host, and making a DHCP reservation for the Xbox with NAT-PMP enabled and disabled without any luck. I have tried factory resetting also which didnt work. I have tried another 5th generation AE and have the same issues but I tried a Netgear router with UPNP enabled and it worked with no problem, however I want to stick with the AE if possible. I know the AE is not on the list of compatible routers for Xbox Live but I know many people use them anyway with no problems. If someone has any suggestions they would be greatly appreciated. If I need to provide any more information about my setup I can do so. Thanks!

  • Tesserax Level 9 (50,469 points)

    It looks like you have already tried all the possible suggestions that I can offer. Unfortunately, the AirPorts are not listed as Xbox Live-compatible routers ... so there is no guarantee doing this will get Open NAT status for Xbox Live!


    The following web blog does a great job explaining the NAT issues with Xbox Live! Basically what it comes down to is that although you can get an Internet connection for the Xbox with the AirPorts, you may not get the necessary NAT setting (Moderate or Open) for the Xbox Live! on-line game that you want to play. As such, you basically have two options: 1) Create a DMZ (Apple calls this a Default Host) for the XBox or 2) Configure the AirPort for Port mapping to open the required ports to allow Xbox Live! access ... or 3) Use a compatible router.

  • Wildb0yz Level 1 (0 points)

    Thank you for your response. It looks like I have tried all the available options and its just something I will have to live with. Thanks again.

  • SeekingSophia Level 1 (0 points)

    Found this video with instructions and it worked like a charm!



  • slmccormick Level 1 (0 points)

    I set up a DMZ for my XBOX's IP address and it works like a charm now. I first tried the port mapping and it didn't work right. Thanks Tesserax this has been driving me nuts.

  • slmccormick Level 1 (0 points)

    I'm not sure if anyone is still having these issues but mine came right back after a day or so. I finally believe that I have it licked.


    After assigning a static IP to my xbox and then adding that to the default host (DMZ) setting on my Airport Extreme, my xbox still wouldn't auto sign into xbox live when turned on. I would always have to run the network test and it would pass and then allow me to sign in. I kept thinking this is some sort of issue with the Airport Extreme since when I set it up with a different router (dlink) the issue never occured.


    It turns out that it's some sort of bug with the xbox and the way to resolve it is by setting manual DNS servers on the xbox. Which is the next setting down from the manual IP entries. I just gave it the google DNS's and Now it's working great and has been for the last week. I know that this isn't an Airport Extreme issue but since it only occurs with the extreme I thought I'd throw it on here.


    Here is a link to the site I found this solution on.


    http://www.davidwhitney.co.uk/Blog/2008/11/19/xbox-live-connection-bug-live-wont -automatically-connect-until-you-perform-a-network-test/