Skip navigation

iBook G4 Charger not working

325 Views 0 Replies Latest reply: Nov 13, 2012 5:42 PM by johnbaker958 RSS
johnbaker958 Calculating status...
Currently Being Moderated
Nov 13, 2012 5:42 PM

Hello, I have a iBook G4 running OS X 10.5.6. When I first got the computer, the charger worked fine.

It was not the original apple charger. Then it would not start charging I had to put a lot of pressure just to make it charge. It was annoying so I used my sisters PowerBook G4 Charger to charge it, and it worked fine. This was the real apple charger. If I need a new one, where can I get a brand new one??

Thank you for Your help!

 

 

PS I just upgraded to leopard could that be the problem?

iBook, Mac OS X (10.5.6), 1.07 Ghz PowerPC G4

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.