2 Replies Latest reply: May 17, 2013 10:31 AM by Kanad
greatalps123 Level 1 Level 1 (0 points)

I have added the google Talk account in the messages application. But only the jabber account shows in the main window, which was there by default. Am I adding the account properly. Should Messages work like the Windows Google Talk application ?


MacBook Pro
  • 1. Re: Google Talk not working with Messages
    Ralph Johns (UK) Level 9 Level 9 (67,515 points)

    HI,

     

    This is somewhat a hangover from the iChat days.

     

    In Messages > Preferences > Accounts  is the GoogleTalk account listed as  Gmail item ?

    IF you highlight it and go to "Server Settings" is the server talk.google.com ?

     

    Now go to the Window Menu

    Select the Buddies item (you probably still have a combined list)

    The Buddy List should now appear.

    GO to the Preferences > General section and untick the item about gathering Buddy list into one list

     

    You may now have more than one Buddy list

    Instead of being called "Buddies" it will take on the name of the Account ....

    The exceptions to this are:-

    Generic AIM Logins will be Called AIM Buddy List if there is only one

    Generic Jabber Logins will lbe listed as "Jabber" Buddy list if there is only one Jabber list

    (you can also have Yahoo and Bonjour)

     

    IF in the Preferences > Accounts you add details to the Description Line  then the Buddy List gets called this

    IF you don't name or Describe the accounts and have more than one (Jabber and /or AIM) then they get named with the Screen Name or ID.

     

    Account and Buddy list "Named"

    Screen Shot 2012-11-14 at 22.44.12.png

     

    This now carries over to the text entry field/box in the main Messages Window where the ID or Screen Name you will be chatting from is listed in that Text field.

     

    IF you only have one Jabber Account And Googletalk is a Jabber account it will read "Jabber" unless you have more Jabber accounts or add a Description

     

    Jabber Description.png

     

     

     

    Sigcopy2.png
    10:50 PM      Wednesday; November 14, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • 2. Re: Google Talk not working with Messages
    Kanad Level 1 Level 1 (5 points)

    I too had the the same problem, but i solved it by the followin method.

     

    Step 1 : Enable 2 setp verification from gmail.com (https://www.google.com/settings/security)

     

    Step 2 : Go to Manage in Connected applications and sites tab

     

    Step 3 : Generate application specific password.

     

    Step 4 : Now go to system preferences > Mail, Contacts & Calenders > Google tab (If already) > details> enter your username and then the application specific password

     

    Step 5 : In iChat preferences , you'll now see the google acc with greyed out username and password and a single option of Enable this account.

     

    Step 6 : Now it should work