7 Replies Latest reply: Nov 15, 2012 3:17 AM by tnoi
tnoi Level 1 Level 1 (0 points)

A while ago I upgraded the Aperture to 3.3.2. After that I noticed that I missed all my faces so I fixed permissions, repaired database and and rebuilt the database.

 

and then upgraded it to 3.4.2.

 

Only after having done all of that I noticed that I had lost all my folders and smart folders as well, I  however, don't know where in the process they got lost.

 

I have an old backup but I'm afraid that I have added to much photos since. But I am not so concerned over the fact that I have to recreate a lot of folder, but what do concern me more is that I am losing confidence in the library management.

 

Could someone help me clarify where in the process these problems can occur and how to avoid them?

Is there something that I should verify myself after certain actions?


Aperture 3, Mac OS X (10.7.5)
  • léonie Level 9 Level 9 (68,120 points)

    Only after having done all of that I noticed that I had lost all my folders and smart folders as well, I  however, don't know where in the process they got lost.

    Do you mean albums and smart albums? There are no smart folders in Aperture.

     

    If it is smart albums you are asking about - albums now have their own section in the Library inspector pane. This section can be hidden. Have you checked, if you see an "ALBUMS" headline in the Library, with nothing below? Then hover your mouse to the right of this caption - this should reveal a "Show" button. press it.

     

    Does this bring the albums back? Other secctions may be hidden as well, your projects for example.

     

    If that is not the problem post back with more information on your Aperture library - its location, if referenced or managed, does it contain iPhoto projects,  anything else you might consider useful.

     

     

    hiddenalbums.png

     

    Regards

    Léonie

  • tnoi Level 1 Level 1 (0 points)

    Indeed, I mean albums and not folders. And I do see the Album section, but there is not much.

     

    All smart albums I have created under projects are gone, so are the albums. The photos seems to all be there.

     

    I only use aperture and all photos are managed. The library is about 90 Gb including some videos.

  • léonie Level 9 Level 9 (68,120 points)

    Just to be sure - have you checked the search field in the Library inspector, if it is cleared? If the search field is not empty, many of your albums and projects may be hidden, even if you see all images in the photos view.

  • shuttersp33d Level 4 Level 4 (1,540 points)

    In addition to what Leonie is saying, when you indicate that you can not see any album or smart albums in your Projects... have you clicked on the reveal arrow to the left of the Project title?

     

    Screen Shot 2012-11-14 at 11.38.30 AM.png

  • tnoi Level 1 Level 1 (0 points)

    Search field is empty and I have clicked on the arrow to reveal it.

     

    Screen Shot 2012-11-15 at 07.18.36.png

  • shuttersp33d Level 4 Level 4 (1,540 points)

    So, it looks like you have more stuff in these subfolders. I'm assuming by your response, not the Albums and Smart Albums you were looking for?

  • tnoi Level 1 Level 1 (0 points)

    Indeed, I had plenty if Smart albums in the "Workflow" folder.