Previous 1 2 Next 20 Replies Latest reply: Mar 19, 2014 11:09 PM by graceberry
Juliet zhang Level 1 Level 1

Recently I can't open google and any google related websites like google translate using my macbook pro.

 

I have tried different browsers, like firefox, safari and google chrome. None of them works.

 

Also, I tried different network. I have tried to open google under my home network, my office network and other public networks. None of them works.

 

And I have tried using Network Utility to tracerout. It can't stop and keep tracing. Shown as below.

Screen Shot 2012-11-14 at 11.40.58 AM.png

I have been struggling with this problem for couple of days.

 

Can anyone help me?

 

Thanks a lot!


MacBook Pro (13-inch Early 2011), Mac OS X (10.7.5)
Solved by Linc Davis on Nov 15, 2012 2:27 PM Solved

Your system has been hacked to redirect Google connections to a server in China. How that happened, I don't know.

 

Please read this whole message before doing anything.

 

Back up all data.

 

These instructions must be carried out in an administrator account, if you have more than one user account.

 

Launch the Terminal application in any of the following ways:

 

☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

 

☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

 

☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

 

Copy or drag — do not type — the line of text below into the Terminal window, then press return:

 

open /etc/hosts

 

A TextEdit window should open. At the top of the window, you should see something like this:

 

##

# Host Database

#

# localhost is used to configure the loopback interface

# when the system is booting.  Do not change this entry.

##

127.0.0.1                              localhost

255.255.255.255          broadcasthost

::1                                        localhost

fe80::1%lo0                    localhost

 

Below that, you'll see some other lines. There should be nothing before the first line above. Make sure you scroll all the way to the bottom of the document. In OS X 10.7 or later, scroll bars are hidden by default until you actually start scrolling, so you may not realize that you’re not seeing the whole document.

 

If the contents of the TextEdit window are as described, close it, then enter the following command in the Terminal window in the same way as before; i.e., without typing:

 

sed '/lo0/q' !$ > Desktop/hosts

 

You should now have a file named "hosts" on your Desktop. Double-click the file to open it in TextEdit, and verify that it has only the contents shown above, with any extra lines removed. If so, close the window without making any changes.

 

Next, go back to the Terminal window and enter one final command, again without typing:

 

sudo sh -c 'cat Desktop/hosts > /etc/hosts'

 

This time, you'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. Confirm. Quit Terminal.

 

Do not type anything in the Terminal window except your password.

 

That will fix the hosts file. You can now delete the file that was created on your Desktop.

Reply by CMCSK on Nov 15, 2012 10:47 AM Helpful

DNS Information - Check to see if an extra entry is present in the DNS Tab for your wireless connection (System Preferences/Network/Airport/Advanced/DNS).

Delete all extra entries that you find.

Place a check mark next to "Remember networks this computer has joined."

 

 

Non-responsive DNS server or invalid DNS configuration can cause long delay before webpages load

 

 

 

 

 

 

 

 

 

 

 

 

 

dancingsmilie.gif

Reply by Linc Davis on Nov 15, 2012 10:40 AM Helpful

The name server at 208.67.222.222 is not returning correct results. That's OpenDNS, which I would never use. If you're getting the DNS settings from your router, change them there. Probably all you need to do is remove the OpenDNS addresses, and it will automatically add the addresses of your ISP's servers from DHCP.

 

If the servers are set in the Network preference pane, change them there.

All replies

Previous 1 2 Next