Previous 1 2 Next 20 Replies Latest reply: Mar 19, 2014 11:09 PM by graceberry Go to original post
  • Linc Davis Level 10 Level 10 (160,025 points)

    Your system has been hacked to redirect Google connections to a server in China. How that happened, I don't know.


    Please read this whole message before doing anything.


    Back up all data.


    These instructions must be carried out in an administrator account, if you have more than one user account.


    Launch the Terminal application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.


    Copy or drag — do not type — the line of text below into the Terminal window, then press return:


    open /etc/hosts


    A TextEdit window should open. At the top of the window, you should see something like this:



    # Host Database


    # localhost is used to configure the loopback interface

    # when the system is booting.  Do not change this entry.

    ##                              localhost          broadcasthost

    ::1                                        localhost

    fe80::1%lo0                    localhost


    Below that, you'll see some other lines. There should be nothing before the first line above. Make sure you scroll all the way to the bottom of the document. In OS X 10.7 or later, scroll bars are hidden by default until you actually start scrolling, so you may not realize that you’re not seeing the whole document.


    If the contents of the TextEdit window are as described, close it, then enter the following command in the Terminal window in the same way as before; i.e., without typing:


    sed '/lo0/q' !$ > Desktop/hosts


    You should now have a file named "hosts" on your Desktop. Double-click the file to open it in TextEdit, and verify that it has only the contents shown above, with any extra lines removed. If so, close the window without making any changes.


    Next, go back to the Terminal window and enter one final command, again without typing:


    sudo sh -c 'cat Desktop/hosts > /etc/hosts'


    This time, you'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. Confirm. Quit Terminal.


    Do not type anything in the Terminal window except your password.


    That will fix the hosts file. You can now delete the file that was created on your Desktop.

  • Juliet zhang Level 1 Level 1 (0 points)

    Thanks a lot!

    It really works!



  • efaulk03 Level 1 Level 1 (0 points)

    Came across this solution as I was having this same issue, and it worked temporarily but it seemed like it reverted as I cant access only on my Mac. Phones, other computer are fine. Any solutions for permanently fixing it?

  • jemmadix Level 1 Level 1 (0 points)

    thanks linc! solved my problem.

  • jemmadix Level 1 Level 1 (0 points)

    btw should i be concerned? is there anything else i should check?

  • graceberry Level 1 Level 1 (0 points)


    I have the same problem, and I tried to do exactly like you said. But still it doesn't change the problem.

    I still can't open

    and occasionally it says, "your flash player may be out of date"

    but I did update my flash player, and nothing changed.


    please help. I am so desperate.

Previous 1 2 Next