2 Replies Latest reply: Nov 20, 2012 9:46 AM by Anthony J
Anthony J Level 1 Level 1 (0 points)

We recently upgraded from 10.6 server to 10.8 server and are having trouble with AFP shares and Active Directory.  We have shares on each of our OS X servers that should be mountable by any Active Directory user at the site the server resides.  In 10.6, this worked beautifully.  Simply adding the appropriate AD groups with appropriate permissions to the ACL of the folder(s) being shared worked without a hitch.  In 10.8 server, this is not working.  Permissions are defined correctly (as far as I can tell), the server is bound to AD, but yet no AD user who should have access can mount the share.  When attempting to mount the share on a 10.6 client, the user gets the short and simple "You entered an invalid username or password.  Please try again."  On a 10.7 client, the window shakes. 

 

What confuses me even more is that no local users can mount the share as well.  I try as our admin account, I receive the following error message on our 10.6 clients:

 

Actually, as I was forumulating this post, logging in as the server administrator account is now working...???!!!

 

This was the error message we were receiving on 10.7 clients before it magically started working:

 

Screen Shot 2012-11-14 at 10.48.02 AM.png

In any case, authenticating as an AD user is still no go.  Any ideas?


OS X Server