1 Reply Latest reply: Nov 14, 2012 5:11 PM by roaminggnome
Kuper1984 Level 1 Level 1 (0 points)

I just got the iphone 5, when i hook up to i tunes it says that I need itunes10.7, how do I proceed


iPhone 5, iOS 6