0 Replies Latest reply: Nov 14, 2012 7:00 PM by Christopher Graham5
Christopher Graham5 Level 1 Level 1 (20 points)



After having the issue with home sharing not showing up from my MacBook to my Apple TV or any other Mac in tested, I dug in and found a fix in my case.


Using tcpdump, I noticed that the notification for the home share library would never be broadcast from the MacBook to the other clients. Without having iTunes running, in the Termnial (Applications > Utilities > Terminal.app), I used this command


sudo tcpdump -i en0 -n -nn port 5353 or port 3689


I then started iTunes where I should have seen a broadcast message of this type.Where all the items in "< >" are specific to you machine and library.


21:35:55.234901 IP <IP>.5353 > 0*- [0q] 9/0/5 (Cache flush) TXT "txtvers=1" "Version=<ID>" "MID=0x<ID>" "Database ID=<ID>" "Machine ID=<ID>" "dmv=131080" "OSsi=0x1F5" "Media Kinds Shared=3211503" "iTSh Version=196616" "Password=1" "Machine Name=<Library>", PTR _daap._tcp.local., PTR <Library>_PW._daap._tcp.local., (Cache flush) TXT "txtvers=1" "dmv=131080" "hQ=2289" "MID=<ID>" "Version=196619" "iTSh Version=196616" "PrVs=65538" "Machine Name=<Library>" "OSsi=0x1F5" "hG=<ID>" "Database ID=<ID>" "Machine ID=<ID>" "hC=<ID>", PTR _home-sharing._tcp.local., PTR <Library>._home-sharing._tcp.local., PTR <Library>._home-sharing._tcp.local., (Cache flush) SRV <Machine>.local.:49152 0 0, (Cache flush) SRV <Machine>.local.:49152 0 0 (861)


I was not seeing that particular message from my machine being sent to the network, so none of the machines ever were notified of the home share.


So, knowing that home sharing is bonjour based, I looked to see if that was enabled, and saw that it was not.

There are lots of entries to search for enabling or disabling bonjour, but this is the page that I followed, but in reverse, as in ...

I removed the "<string>-NoMulticastAdvertisements</string>" option ...


Mac OS X v10.6: Disabling mDNSResponder will disable DNS



Be very careful in editing that file per the directions.


Then using the Terminal command, I stopped it and restarted mDNSResponder. A reboot will do the same.

Be very careful in editing that file per the directions.


To disable

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist


To enable:

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist


After that I have had no problems in seeing my shares on the network.