1 Reply Latest reply: Dec 5, 2012 6:47 PM by UptimeJeff
Ricardo Luz Level 1 Level 1 (15 points)

I have encountered a strange problem i have never seen before and it has me a bit baffled.

 

Current setup:

Mac OS X 10.6 server with the Mail service running and everyone using IMAP to connect to their mail.  They are using apples mail client.

 

I have a user seems to have lost all his mail from his inbox.  All the sub folders are still in tact but the inbox is completely blank.  At first i thought the user might have accidently deleted all his email but that wasn't the case.  I can confirm that the issue is not on the client machine as when i log in with webmail directly on the server, it shows the same thing.

 

I have a backup that is a few days old but i am hoping to avoid having to figure out how to copy the users mailbox back from that as they have a lot of emails that they have received in the past few days.

 

I have repaired the permissions on the server in case the mailstore had corrupted permission but this didn't work completely, i am now receiving emails into that inbox but all the previous messages didn't come back.

 

I am pretty stuck as to what i can do from here and any help would be welcomed


Mac Pro, OS X Server, 10.6
  • 1. Re: Mac OS X 10.6 Server user mail account rebuild
    UptimeJeff Level 4 Level 4 (3,390 points)

    each message is a file..

    look directly in the mailstore for that user. Most of the inbox will be in the cur directory.

    are the messages there?

     

    If they are gone, then they are gone.. most likely deleted..

     

    If you have a backup, they can be reinserted easily (make sure permissions are correct)