Previous 1 2 Next 24 Replies Latest reply: Jan 30, 2013 3:44 AM by Knighstalker Go to original post
  • Vetebullen Level 1 Level 1 (0 points)

    Thanks for the tip, but it didn't work for me...

  • Vetebullen Level 1 Level 1 (0 points)

    If I understand you correctly, you mean the startup.prefpane. I have tried this already and it didn't work. Thanks anyway.

  • David M Brewer Level 6 Level 6 (9,270 points)

    Here you go... Use the Automator app (in your application folder) and build this workflow:

     

    Screen Shot 2012-11-19 at 12.04.05 AM.png

    Save this workflow as a 'workflow' and as an '(shutdown) application'. Save both the workflow and (shutdown) application to your Document folder. Drag the (shutdown) application that you just made to your dock. Click on the (shutdown) application in your dock when you want to shutdown/mute sound. This all take less a second or two to execute. (Let go of the mouse when running this... you will see the pointer moving on the screen to open the System Preferences/Sound Preferences/Mute check box.)

     

    You can also make an un-mute application that execute when you startup the computer. Just delete the Run Applescript section and have the 'un-mute application' open at startup.

     

    It's late and I have to dash... I hope you understand the above... I'm not an Automator or Applescript guru... I'm sure you can figure it out. If not there are others here to help you with it.

  • Vetebullen Level 1 Level 1 (0 points)

    This worked for one startup, then stopped working. Thanks anyway.

  • Vetebullen Level 1 Level 1 (0 points)

    This will not work if I shut down the computer with head phones plugged in and boot it with them unplugged (or the other way 'round), right? (Since those are different sound settings). Thanks anyway!

  • Vetebullen Level 1 Level 1 (0 points)

    This will not help if I for example shut down the computer with headphones plugged in and boot it with them unplugged, right? (Since those are different settings, and only one is available at a time). Thanks anyway!

  • Vetebullen Level 1 Level 1 (0 points)

    Update: This problem is still unresolved. I have tried all the suggestions so far, and none have worked satisfactory (satisfactory meaning that the chime is always off when I start and not just occasionally). I am however thankful for the many suggestions. The reason one of the suggestions is marked as an answer is because of a misclick, which (apparently) cannot be undone (for mysterious reasons). I couldn't find any way to post this update in my original question, sorry about that. Further suggestions are welcome and appreciated.

  • David M Brewer Level 6 Level 6 (9,270 points)

    It only worked one time because you didn't turn on your sound when the computer restarted. I told you you can have the sound un-mute at startup by removing the Applescript. You need to place the startup app in your login items.

     

    Screen Shot 2012-11-19 at 8.21.52 AM.png

  • Vetebullen Level 1 Level 1 (0 points)

    "It only worked one time because you didn't turn on your sound when the computer restarted. I told you you can have the sound un-mute at startup by removing the Applescript. You need to place the startup app in your login items."

    I think there is a confusion because all my replies stack up at the end of the discussion (I thought they would appear next to the comment they replied to, which imho should be the intuitive way to do it. I guess I have to cite what I'm replying to). The reply about only working once was about cocktail. The reply concerning the applescript was this: "This will not help if I for example shut down the computer with headphones plugged in and boot it with them unplugged, right? (Since those are different settings, and only one is available at a time). Thanks anyway!" Does this sound reasonable?

Previous 1 2 Next