4 Replies Latest reply: Nov 15, 2012 3:49 AM by sirdavd
sirdavd Level 1 (0 points)

I've been trying to test my podcast setup through iTunes before properly uploading the first few episodes and submitting them to the store. When I go to Advanced -> Subscribe to Podcast via iTunes and enter my feed (http://www.silverscreensnobs.com/podcast/feed.xml) a generic icon appears with no information and does not download anything. It's like it just doesn't recognise the link. In fact, I tried putting a typo in the link, added it and had the same result - it just sits there and nothing happens so something's obviously wrong... When I try adding other podcasts this way they behave normally and start downloading instantly.


I have been searching through these forums for an answer with no luck. When I use my iPad and use a podcast app (iCatcher, to be specific) and enter my feed it instantly comes up with the three test MP3s and the option to subscribe so I don't think it's the feed... I have tried two different computers (Windows) using iTunes and have come up with this problem on both machines.


I would greatly appreciate any help, thanks.

Windows 7