0 Replies Latest reply: Nov 15, 2012 4:51 AM by TheMisfit
TheMisfit Level 1 Level 1 (0 points)



Im trying to setup my own private Git-repository using OS X Mountain Lion Server and

want it to work using smart HTTP://


Using te 'Server' application:


I've made a DNS-entry for mygitserver.mydomain.com and it resolves just fine.

I've made a virtual website for mygitserver.mydomain.com,

used /volumes/myDataDisk/git/allMyRepostories/ as the sites home-directory and

in the advanced settings allowed for 'CGI-execution'.

I changed permissions on the 'allMyRepostories'-folder and its subfolders to allow "Full control" for _www.


Using the 'Terminal' application and 'Coda' as my text-editor:


I tried editing both the main apache config file 'httpd.conf' and

my sites configuration file '0000_any_80_mygitserver.mydomain.com.conf'

as descibed in:

http://developer.apple.com/library/mac/#documentation/Darwin/Reference/ManPages/ man1/git-http-backend.1.html


Bottom line, I can pull but I can't push (tried XCode, Gitbox and the Terminal as a client)

I get fatal error 22. It is driving me crazy :-(


Also I wonder, if you configured a "required group" to have access to a certain apache directory,

can you use an open directory groupname like 'Developers" and can it be used in titlecase or should one use the shortname (all lowercase).


pleeeeaaaase help.


Mac mini, OS X Server