3 Replies Latest reply: Nov 16, 2012 11:29 AM by BenB
E.Largo Level 1 (5 points)

I have tried all of the work arounds I have been able to find in the Support Commnity and still I can't change the duration of source clips in Motion 5.  I have trashed plist, rebooted, repaired permisions, changed timing of project, changed name of clip, used the Timeline clock instead of the Instpector window.  Cleared all In / Out points and reset them to slightly different values. I have changed Timing to Variable and back again.  I can open clips in a new project and change duration.  I have opened new project and copied some layers from working project, the problem persists.  Is reinstall the option left available to me?

  • BenB Level 6 (9,065 points)

    Not exactly sure what you mean.  QuickTime video clips or still images?  Your clips in Motion 5 are limited to two durations.  The first limit is the duration of the Project itself.  If the clip is longer than the project, make the project itself longer in duration.  The second limit is the video clip's own native duration.


    Aside from that, there are no known bugs about clip durations.  So here's some questions to clarify what you may or may not be trying to do.


    What is the codec/format of the clip you're importing into Motion as a layer object?

    What is that video clip's physical duration?

    What is the duration of the Motion project you're working in?

  • E.Largo Level 1 (5 points)


    The specifics: Motion 5.0.4 Timeline is set to 6 minutes, the Media is 5:59;21 (QT,mp4, H264,1280x720, 24fps). Imported via File Browser into Layer Group (Group In / Out points are 0 and 6 mins, as is Play Range).  At one time the clip was in it's full duration.  Afterr a crash / restart it is only 01:52;27.  I can not Drag the clip to its full length. I cannot change it's duration thru the Inspector, not the Timeline Clock. 


    In an effort to isolate the issue I opened a new Project (same time setttings as original Project, imported the clip, which plays to it's full duration, and then, one at a time, copied and pasted all Filters and Parameters and Objects from the original Project; all play fine.  Then I copied the original Layer Group in it's entirety to the Test Project, and the clip is still limited to 01:52;27.  I then used Replace Media to select a random clips (same format) with varying Duration (all longer than 01:52;27) and got the same result every time; Duraton 01:52;27. Not one element of the Test Project has an In / Out set to anything other than the full Duration of the Project.

  • BenB Level 6 (9,065 points)

    That is odd, I've never seen that, can't replicate it.  Sounds like a bug.  Fill out the feedback page (link in the Motion menu) with details.


    Also, in Motion's preferences, make sure you have Auto Save set to save a copy every 5 minutes, 12 copies, and about the last 4 projects opened.  This way if you have an issue, you can go back between 5 minutes and 1 hour.


    The only think I can think of that would casue something like this is if the start of the clip is before the start of the project itself.  I'd drag the clip left a bit to leave blank space in the timeline before it, then try to drag the start of the clip to the left.  Otherwise, you have some sort of bug going on there.