1 Reply Latest reply: Nov 15, 2012 3:09 PM by Mini-Mac
Mini-Mac Level 3 (805 points)

I'll start off by saying once upon a time Apple products worked togather with only minor hiccups.  Not ture any more!!!!!!!!!  Why because they rush products/softwater/firmware out the door without fully testing and so much intergration with iOS and not enough focus on the bread and butter of Apple's legacy (Steve Jobs perfection first).


The not so simpe fix:


1.  Wireless router (one and only one) in other words NO additional wireless routers connected in bridge mode to extend wireless capabilities.

2.  Assign a wirelss Client ID on your computer. For Mac open (System Perferences - Network - WiFi - Preferences - TCP/IP - DHCP Client ID:)

3.  On your router setup a DHCP Reservation. On a Apple router open Network - + to add Reservation - use DHCP Client ID not Mac Address.  

     Enter the same name as you used on you computer.  Enter a IP address such as

4.  Shut down computer

5.  Shut down router

6.  After router restarts, restart computer and see if the IP address is the same as you reserved on your router, (if not you did something wrong).

7.  Repeat the same (#2, #3, #4, #5, #6) for the ATV.  Your ATV client ID is what you named it.  You can fine out the name of your ATV by goin to Settings-         General - Name.  If you use spaces between words you have to add them as well.  Note:  #3 must be different such as

8.  Open iTunes on the host computer and insure Home Sharing is enabled.

9.  On the host computer (for Mac) open System Preferences - Energy Saver and move the slider for the Computer Sleep to NEVER. 




This process has worked for me, and has never filed.


Until Apple figures out why ATV is not waking your computer and dropping your Home Sharing connection you can use the above steps.


Hopefully this helps someone else!

MacBook Pro, OS X Mountain Lion (10.8.1), 2012 MBP 15.4 2.6 i7 Quad USB3