7 Replies Latest reply: Feb 1, 2013 8:14 AM by TStam
crumrine Level 1 Level 1

I am running Aperture 3.4.3 on a MacPro running MacOS 10.7.5 and am unable to run Aperture.  When I launch Aperture it hangs with a dialog box open saying "Opening Aperture Library".  When looking at the menu bar, it is showing all the correct Aperture Menu's but I can't do anything because the library won't open.  I have tried repairing the premissions and repairing the library.  The only thing that seems to work is trashing Aperture and re-installing which is really annoying espcially since I do not have a MacApp store version.   This also seems to be happening on a weekly basis.  Any other suggestions for fixes would be much appriciated.

Aperture 3, Mac OS X (10.7.5)
  • Aye Es Oh Level 2 Level 2

    Do you have this issue with other libraries or only your main library? If other libraries are OK, I'd try working with a different library for a while to see if that eventually manifests the issue as well.

  • shuttersp33d Level 4 Level 4

    How long do you wait when it gives you the message that it is opening the library? Do you then force quit the application? Have you tried just letting it go?

  • crumrine Level 1 Level 1

    This is happening to all my libraries and the window with the little spinner shows up right away.  I have tried letting it go and it never finishes.  I can just quit the application normally, I don't have to Force Quit, because I have a lot the menu items avaliable (they just don't do anything).

  • Aye Es Oh Level 2 Level 2

    Does Aperture still stall when you use it in a different user account?

  • crumrine Level 1 Level 1

    This is happening with all user accounts.

  • McGIO Level 1 Level 1

    I am experiencing the same issue, any solutions?

  • TStam Level 1 Level 1

    Same happening here. I've tried every posted fix. Until now the only fix that worked for me was reinstalling Aperture and updates. For me I go about two weeks until the problem recurs. Very frustrating. It happened again today. This time I tried something different. I deleted the Aperture application and dragged the Aperture application from a backup I created yesterday back into my finder applications folder. The program launched right away.


    This means something is actually getting corrupted in the Aperture program file itself and not the library. Strange. While i'd prefer the program to just work correctly, my fix took about 3 seconds.