Skip navigation

os x server mail push no more available calendar still pushing

3919 Views 23 Replies Latest reply: Jan 29, 2013 9:40 AM by Oliver.F. RSS
1 2 Previous Next
eldrik Level 1 Level 1 (65 points)
Currently Being Moderated
Nov 15, 2012 11:10 PM

Hi,

 

suddenly my os x server 10.8.2 seems to stopped working when it comes to mail.


Viewing the push option on my iphone or ipad there is no more push available while for the ical caldav calendar push is still available and working.

 

Is there a way to debug on the server where might the problem be? On which logs I need to search?

 

It was working reliable in the past and I don't know why it stopped working.

 

Any help is appreciated.

 

Regards

eldrik

Mac mini Server (Mid 2011), OS X Mountain Lion, runs OS X Server on VM Fusion 4
  • infinite vortex Calculating status...

    Try turning off push and then turning it back on in Server.app. Failing that, they getting a new certificate.

  • infinite vortex Level 7 Level 7 (21,400 points)

    Funny, the same thing just happened to me and my iPhone just now. Disabling the Mail & Notes account, quitting Mail if it's running, and then reenabling it seemed to do the job in getting it back.

  • jroegner Calculating status...

    I have the same problem. With my Lion Server worked fine and pushed new mails from my own mail server on the mac mini to my iOS devices. Now I'm using Mountain Lion with the Server App and I can't receive push mails on my devices. I also have new push certificates from apple. I'm not using the Profile Manager (With Lion Server I also didn't use it, and push worked!). So I can't set the Mail Notifications to Push on my devices for the mail account on my ML Server.

    When I filter the Console on the Server I can see the following messages:

     

    16.11.12 17:58:49,142 push_notify[14519]: Opening connection to apn feedback server feedback.push.apple.com for topic com.apple.mail.XServer.64a87de9-5f35-42d3-9cb0-0631b8942ff8

     

    16.11.12 17:58:54,697 push_notify[14519]: Disconnected from apn feedback server feedback.push.apple.com for topic com.apple.mail.XServer.64a87de9-5f35-42d3-9cb0-0631b8942ff8

     

    16.11.12 18:15:12,445 apsd[84]: <APSConnectionNotificationQueue: 0x7fa8d48537d0>: outstanding count -1 for com.apple.apsd-queue-port=com.apple.syncdefaultsd.push-user=501-env=production

     

    The Last message repeats more and more. Is the server trying to push, but has a failure? I don't understand the output.

     

    Greets

  • mrecker Calculating status...

    Hi, do have the same issue since I reinstalled a fresh ML server yesterday. Hopefully somebody has a hint for us.

    Cheers

  • fight_or_flight Calculating status...

    I'm glad to hear that i am not the only one who has problems with push mail.

    My first thought was also that the server has a problem but after reading the thread, i think it could maybe be iOS.

    All my devices run 6.01 and all of them are fetching mails from the ML server.

    How is ML reciving the mails from the server? Are these mails also pushed or rather fetched?

  • menzbua Calculating status...

    I have the same Problem with Push Mail but on Lion Server:

    https://discussions.apple.com/thread/4522871?tstart=0

     

    I think this is not a Problem on the server but rather in IOS 6.0.1. I cannot swear but i think push is broken since i updated my devices to the new IOS Version.

     

    Hopefully our Problem would be solved soon.

     

    Best Regards

    Manuel

  • jroegner Level 1 Level 1 (0 points)

    I also would say that this issue does't depent on the used OSX Server. I used a Lion Server for more then one year without having push mail problems. Monday last week I suddenly did not receive any push mail. First I was looking for the problem, but could not find a hint. So I restored a two week old complete time machine backup of my lion server. When the backup was made, push mail worked definetly fine. But also no push. The I decided to install a new blank Mountain Lion Server and did not use any backup. Renewed my push certificates and my signed ssl certificate as well. Everything but push is working propably.

     

    Regards

  • jroegner Level 1 Level 1 (0 points)

    Good, but also bad news,

     

    I'm sure now that it is a problem or bug of the actual iOS. I configured my mail account on my old iPhone 3G with iOS 4.2.1 right now fpr testing. Surprise surprise push can by selected and is also working fine.

    I hope the will be an update for the actual devices very quick.

     

    Regards

  • Levy70 Calculating status...

    Well, same case over here: OS X ML Server with iOS 6.0.1 and no push for mail and contacts. Calendar works with push.

     

    Perhaps somebody at Apple-Support can confirm this case so we don't have to investigate this behaviour furthermore.

     

    Best regards

    Levy

  • fight_or_flight Level 1 Level 1 (10 points)

    Only someone with a developer apple id  can report a bug.  

  • infinite vortex Level 7 Level 7 (21,400 points)

    There is more than one way to report things to Apple. It really comes down to how much it's worth to you. The most available are…

     

    1) Apple Feedback

    http://www.apple.com/feedback/

     

    2) Apple Developer bug reporter (this works even with the free accounts)

    https://developer.apple.com/bugreporter/

     

    The more detailed you are the better. Bear in mind that there's a lot that can go on with a Push event on Poerts TCP2195-2196 from your server that's out of control of Apple ranging from your server setup (firewalls etc), your network topology (DNS plus your Internet connection and provider proxy servers) through to your ISP and your cellular provider etc, and everything in between… and that's before iOS has a chance to do anything right or wrong.

     

    While I'm definitely not absolving Apple of anything (for all I know it may well be their fault), one needs to appreciate that just saying it doesn't work isn't going to get anyone very far. Apple can't predict every single circumstance that OS X Server may find itself in so as many details as you can give would be useful.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.