Skip navigation

MacBook switches to hibernation during sleep

26895 Views 219 Replies Latest reply: Jan 22, 2014 5:48 AM by egsl RSS
  • Summer Storm Pictures Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2013 7:36 AM (in response to hockey_magnet)

    Good point about the hibernate issue. I will set the machine to hibernate at 6-hours before going to sleep myself tonight. If this is a viable solution, it should stand up.

     

    As for that Apple developer page--I hear you. Basically that's how you make the sausage.

     

    For the record, my changes tonight will be the following:

     

    sudo pmset -a autopoweroffdelay 21600

    sudo pmset -a standbydelay 21600

     

    I will not change anything else.

  • koreanricequeen Calculating status...
    Currently Being Moderated
    Jan 6, 2013 10:45 AM (in response to chocobanana)

    I read a while back on this thread, someone made a connection between routers and this probelm. I turned my wifi off last night before closing my computer, and it didn't go into hibernation. Interesting!

     

    I still plan on doing the autopoweroffdelay "fix" but I wonder how/why the wifi connection plays into this.

  • taxipalm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2013 10:50 AM (in response to koreanricequeen)

    This is so weird that this conversation has to be had on a computer built in 2012, w/0 any sure fix.  My new 2012 get's that weird loading bar when i come out of sleep.  Is that what we are talking about here? I don't quite understand this thread fully. Yes, i've read it!  Ive changed my pmset to 0 instead of 3, that's all i can remember right now!  Is this thread a fix for not having that stupid loading bar when waking your cmputer? lol. I find I open my laptop early just to load it, then i wont even use it, WASTING MORE POWER?!  Anyways, your response have been appreciated, and i feel like im learning something.

     

    Sent from my iPod Shuffle

  • hockey_magnet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 7, 2013 9:51 AM (in response to chocobanana)

    For what it's worth I was at the Apple Store today and checked 3 different MBP's on display with pmset -g. Not one even had the autopoweroff command visible, never mind having it set to 0 or whatever. They were all running 10.8.2 so I assume they deleted this command completely since they probably leave these things running all the time and don't want them to hibernate. Just curious that they didn't bother setting it to 0 but just removed it altogether.

  • MTBryan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 7, 2013 1:12 PM (in response to hockey_magnet)

    Hmmm. The ones I checked in Nashville all had the settings available and visible. They were set to '1' and the delay set to 14400, which is stock. Those were 13 inch Macbook Pro with Retina. I couldn't get to the regular MBP. Too many people around.

  • taxipalm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 7, 2013 1:27 PM (in response to MTBryan)

    This is so weird that this conversation has to be had on a computer built in 2012, w/0 any sure fix.  My new 2012 get's that weird loading bar when i come out of sleep.  Is that what we are talking about here? I don't quite understand this thread fully. Yes, i've read it!  Ive changed my pmset to 0 instead of 3, that's all i can remember right now!  Is this thread a fix for not having that stupid loading bar when waking your cmputer? lol. I find I open my laptop early just to load it, then i wont even use it, WASTING MORE POWER?!  Anyways, your response have been appreciated, and i feel like im learning something.

     

    Sent from my iPod Shuffle

     


    If someone wouldn't mind, answering this post i'd be very greatful.

     


    Mainly, is this post trying to address the loading bar coming out of sleep?

  • koreanricequeen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 7, 2013 3:06 PM (in response to taxipalm)

    Yes, this post is about the 'loading bar' coming out of hibernation sleep.

     

    There are a few different solutions, you can read the thread if you want other options. As for me, I put

     

    sudo pmset -a autopoweroffdelay 86400

     

    into terminal and this sets a delay of 24 hours, so you'll rarely, if ever, see your computer in hibernation again.

  • JBig13 Calculating status...
    Currently Being Moderated
    Jan 8, 2013 1:45 PM (in response to MTBryan)

    MTBryan

     

    This is my first ever post on the discussion boards, so if I ramble a bit I'm sorry. I'll try to make it short and sweet. I want to use the "autopoweroffdelay" fix to set the delay to 24 hours, but I've run into a bit of a problem. When I use the pmset -g | grep autopoweroff command, it does not bring up current values like you said. I am hesitant to change anything until I can make sure that the values match the ones that you suggested.

     

    Also, will changing this affect my MBP's ability to go into hibernation when the battery is completely depleted in battery mode? I still want my machine to go into hibernation mode if I leave it until it dies completely. I just don't want the delay to cause it not to hibernate when the battery dies. I want the Mac to run as closely as it did before the 10.8.2 update.

     

    Hopefully I'm making some sense. Like I said, I just want my Mac to run as I know it should. I'll say that this isn't my first Mac. I had a 13'' MacBook White, early 2008 model, before I upgraded to the 13'' MacBook Pro, mid-2012 model that I'm using now. That old MacBook only went into hibernation when the battery died. I want this one to do basically the same thing. I'm sorry if I rambled. I'm going to check the developer page you suggested also, just to see if I was typing something in the Terminal incorrectly. If I get it fixed, then I'll try and post an update, but I might be so excited that my Mac is back to normal that I just forget about it. I've been searching the internet for over a month and half trying to find a fix, and it was only today that I finally figured out the magic words to type into the search bar that lead me to this thread!

  • adam_lloyd Calculating status...
    Currently Being Moderated
    Jan 13, 2013 11:03 AM (in response to JBig13)

    Hello all,

     

    Just wanted to reply as I'm also having this issue.

     

    I took my Macbook 15" Mid 2012 10.8.2 into the Apple store, explained my problem and they hadn't heard of the fault before. As the Mac is brand new they told me to ring the Apple helpline and report the problem to obtain a replacement machine as there was a hardware fault.

     

    New machine has arrived and after using TimeMachine the fault has followed me onto the new Macbook. As much as I like the ease of TM it's a shame that the problem has copied across too.

     

    I hope that this glitch is being looked into and an update is released soon. As I do hate seeing the hibernation screen so often.

  • taxipalm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2013 12:27 PM (in response to adam_lloyd)

    ive just followed the guidance from these post's and I havent seen that pesky loading bar ever since!  Thanks guys

  • adam_lloyd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2013 12:40 PM (in response to taxipalm)

    Taxipalm would you mind just letting me know which setting inparticular worked for you?

     

    Many thanks.

  • taxipalm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2013 12:47 PM (in response to taxipalm)

    I did what this article said to do first

     

    http://www.macworld.com/article/1053471/sleepmode.html

     

    i still got the pesky loader after a long while sleeping

     

    then i used this one  sudo pmset -a autopoweroffdelay 86400  second,

     

    and i havent seen it since

  • hockeymagnet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2013 12:52 PM (in response to adam_lloyd)

    I think we've established this has nothing to do with Time Machine nor should Apple have bothered replacing your MBP. This is a change made in the 10.8.2 update and if you follow the directions in this thread re Auto power off you will eliminate the problem.

  • adam_lloyd Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2013 1:06 PM (in response to hockeymagnet)

    I've just put sudo pmset -a autopoweroffdelay 86400 into Terminal. So let's see what happens in the morning.

  • koreanricequeen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 13, 2013 1:46 PM (in response to adam_lloyd)

    As hockeymagnet said, this probably has nothing to do with timemachine. I also recieved a replacement mbp and it has the same issue as the first one (I don't use timemachine, nor add any of my data or programs, and the hibernation still occured, basically with the computer clean and fresh out of the box).
    My spouse has an identical computer that has NOT been updated to mountain lion (muchless the infamous v10.8.2), and his computer does not go into hibernation.

     

    I suggest changing the autopoweroffdelay as others have, It's what I did and it has resolved the issue for now.

     

    Good luck!

1 ... 6 7 8 9 10 ... 15 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.