Previous 1 4 5 6 7 8 Next 222 Replies Latest reply: Dec 28, 2014 5:21 AM by JohnNY123 Go to original post
  • MTBryan Level 1 Level 1 (0 points)

    Yes Kenneth, I agree. It appears backwards. I have gone probably 16 hours on battery power in sleep mode, and it remained in sleep mode (never went to hibernate). I believe on the old MBP it went from sleep mode to hibernate, on battery power, when it dropped below a certain percentage of battery power. I haven't had a change to try that on this new MBP.

    But it makes no sense to go from sleep to hibernate in only 4 hours, when plugged in.

    UNLESS...

    There is an issue with heat or something when plugged in? Just guessing on that one.

  • koreanricequeen Level 1 Level 1 (0 points)

    But now the question is, why is this happening to only SOME computers? if it was a model-wide "feature" then we'd have nothing to discuss here. My spouse bought an identical mbp 2 months after I did and has not experienced this problem/feature at all.
    It's worth noting that my spouse also never updated to mountain lion. I wonder if that's a contributing factor?

  • JohnNY123 Level 1 Level 1 (5 points)

    MTBryan....Good to know, thanks for the update.

  • JohnNY123 Level 1 Level 1 (5 points)

    Yes Kenneth and MTBryan....It definitely seems like the logic is out of whack.  I agree.  The interesting thing is that the settings we're messing with have parameters for when AC is being used and for when battery is being used and I think they can be set independently.  So conceivably, there are many ways to force the computer to do exactly what we want under both power profiles.

     

    I don't have time to mess with this over the weekend, but I might do some fiddling next week.  There's probably a combination of these settings/parameters to suit everyone's style of computer use.  :-)

     

    Koreanricequeen....This behavior seems to have been introduced with the most recent Mountain Lion patch, so if you're spouse hasn't updated to Mountain Lion then that's probably why he doesn't see this issue.

  • hockeymagnet Level 1 Level 1 (0 points)

    I've been following this and I think you guys have solved it. Changing the delay seting for autopoweroff does fix the problem but it would be nice if we could get it to work as it should - i.e. different settings for battery vs plugged in. For example I'd like the plug in setting to be 48 hours or whatever and under battery maybe 12 hours.

  • JohnNY123 Level 1 Level 1 (5 points)

    Hockeymagnet....Check this page, with specific attention to the Setting parameter.  You can specify different settings for battery and AC power.

     

    http://developer.apple.com/library/mac/#documentation/Darwin/Reference/ManPages/ man1/pmset.1.html

  • JohnNY123 Level 1 Level 1 (5 points)

    The waking when plugging in or unplugging AC can apparently be changed with the 'acwake' setting.  My default out of the box is '0' and I'm going to change it to '1' to see if it stops that momentary wakeup when I plug in or unplug AC.

  • JohnNY123 Level 1 Level 1 (5 points)

    MTBryan...What command did you use to change the delay? 

     

    Was it sudo pmset -a autopoweroffdelay 86400

  • hockeymagnet Level 1 Level 1 (0 points)

    JohnNY123, That's what I ended up using based on MTBryan's comment. Worked for me. I'll look into the link you posted as well, thanks.

  • koreanricequeen Level 1 Level 1 (0 points)

    Update:
    I sat at the apple genius bar for 5 solid hours (so they'd see it go into hibernate) and at the end they handed me a brand new macbook. Remember, this was my 8th trip to the store after 7 major repairs in the last month. Persistence and/or insanity wins!

     

    The genuis bar worker I talked to said it was NOT a "feature" and was NOT related to the OS. He insisted it would affect all computers if it was the OS. Idk, I know little to nothing about computers so it's up to you guys to take his singular opinion or not.

     

    I pressured him to do further testing on the computer and he said he'd be sending it to the apple engineers. As for me, the issue is HOPEFULLY resolved as I have a factory fresh new computer. It's still going to bug me what the real issue is though, best of luck to everyone finding a resolution and maybe even the finite cause.

  • Summer Storm Pictures Level 1 Level 1 (0 points)

    I stick to my last statement concerning an assembly level re-tooling being necessary per my conversation with AppleCare senior-level engineer who spoke off the record.

     

    I see that koreanricequeen confirmed somewhat that an Apple "genius" supported this in another way by saying that this is "not a feature" and replaced her MBPr after many calls. I am basically at this point with AppleCare and could at any time return my MBPr 15-inch.

     

    All that said, out of morbid curiosity or blind optimism, I decided to tinker using the page suggested by JohnNY123 (http://developer.apple.com/library/mac/#documentation/Darwin/Reference/ManPages/ man1/pmset.1.html).

     

    It seems to have worked. I closed the lid to my MBPr around midnight last night, un-plugged it, and took it into the bedroom and around 6AM this morning (5-plus hours later), I woke up, opened the MBPr and it immediately went right to my user-password log-in dialog--no delay or dark screen or anything.

     

    To borrow terminology from the news media, I am "guardedly optimistic" and will observe this over the next few days.

     

    These were the settings which I applied using Terminal:

     

    sudo pmset -a hibernatemode 3

    sudo pmset -a autopoweroff 0

    sudo pmset -a autopoweroffdelay 36000

    sudo pmset -a standby 0

    sudo pmset -a standbydelay 36000

    sudo pmset -a acwake 0

     

    As you can see, I opted for a 10-hour window.

     

    I'll be curious now to see if others vexed for so long with this issue have similar success, and am hopeful that the settings "stick" beyond any expected OS or other future update. At least there's hope and I will update my own experience in a few days, success or failure.

     

    Good luck.

  • hockeymagnet Level 1 Level 1 (0 points)

    No offense to anyone but this is clearly not a hardware issue and implying that you need to buy a new laptop to fix it is just not correct and makes no sense. This was obviously caused by the last update and is extremely wide spread based on other threads in multiple forums, affecting brand new machines as well, including the new retina macbook pro's. IMHO, this was clearly caused by the last update and hopefully will be fixed soon. In any event, to prove it, all you would have to do is find someone with a MBP that does not exhibit this behaviour and run pmset -g to check the autooff setting. It appars tto me that autooff is to blame and that the MBP goes into hibernation when this command is executed, which perhaps it should when running on battert but not on AC for sure..

     

    With respect to the Genius referred to by koreanricequeen, keep in mind: "Remember, this was my 8th trip to the store after 7 major repairs in the last month. Persistence and/or insanity wins!" So I would not put a lot of credence in what she was told., once again, no offense.

     

    I also have no doubt that LONG term, Apple (and Microsoft) would want to move their OS development in the same direction as iOS and limit consumer interaction with the OS but that does not mean that they would need to make this all hardware functionality, but rather just continue moving in the direction they are currently. You also have to keep in mnd that this would never fly with large business users.

     

    One other note on this: I noticed in a nother thread that someone connected this somehow to using his MBP on a 5 GHZ network rather than 2.4. While I can't believe this would be the case I did recently install a new router and started using the 5 GHZ at about the same time this started. It would be easy enough to test by returning all settings to default and switching back to 2.4 but I can't be bothered and it really makes no sense that it would make a difference but others might want to comment.

  • MTBryan Level 1 Level 1 (0 points)

    Yeah, I agree Hockymagnet. I figured maybe people were having other issues that are not the same as mine?

    From what I see, this is NOT a problem with the Macbook Pro, but rather:

    1) A new setting in the OS that maybe shouldn't have been defaulted like it was.

    2) A problem with Apple support for not knowing about this setting and what to do about it.

     

    If your problem is as described here:

    When power is attached to the Mac and you close the lid to sleep, 4 hours later the Mac automatically goes from Sleep mode to Hibernate mode, making it take MUCH longer to wake up.

     

    Then the solution is as follows:

    sudo pmset -a autopoweroff 0

     

    That's it!

     

    All the other setting changes aren't necessary (unless you are trying to do something else).

     

    You can also tweak the autopoweroffdelay time, but I don't see the point in that if you just don't want it to go to Hibernate when the power is attached.

     

    Why did Apple add this setting to the OS? Who knows. I really don't care if I can turn that sucker off, which I did.

     

    I wish Apple support would read this thread. I emailed them and asked if they wanted to know the problem and solution, but they replied and just said they closed my ticket (the ticket I submitted asking about this issue, which they couldn't answer). So, they didn't really want to know.

     

    As far as replacing the Mac, the only good that will do is if they have changed that setting on newer Mac's shipped out the door.

     

    Today, I am going to the local Apple store to look at some accessories. I am curious if the models on the floor have that setting turned off (autopoweroff set to '0'). I will try it out.

  • hockeymagnet Level 1 Level 1 (0 points)

    I agree completely. I will likely get around to setting the autopoweroff setting to power off if on battery after say 6 hours or something like that and turn it off for or set a very long delay for when plugged in.   Let us know what you find out at the apple store. However since the floor models would likely never be sleeping for 4 hours, the setting wouldn't really affect them. 

  • hockeymagnet Level 1 Level 1 (0 points)

    none of the settings matter other than the autopoweroff setting and if you set autopoweroff to 0, the autopoweroff delay won't matter and you won't get a 10 hour window, it will never autopoweroff. 

Previous 1 4 5 6 7 8 Next