Previous 1 5 6 7 8 9 Next 224 Replies Latest reply: Jul 19, 2015 3:27 AM by crystalship Go to original post
  • JohnNY123 Level 1 Level 1 (5 points)

    Hockeymagnet....I agree, this is now clearly not a hardware problem.  I was thinking that all along because my Mac did not behave like this when I bought it.  It only changed after the last OSX update.  Now it's "back to normal".  :-)

     

    MTBryan.....I agree with your summary.   If people are experiencing what you described then sudo pmset -a autopoweroff 0 should solve it.  I also tweaked the hybernatemode setting because I didn't want the mem-to-disk delay when I shut the lid.

     

    With that said, I don't think I have any more to say on this topic and I think we've all done a smashing job figuring out our own problem.  Nice work everyone!

  • taxipalm Level 1 Level 1 (0 points)

    changing those settings also made my macbook pro mid 2012 much more speedy to wake and seems in general.  I got the instructions from this article, also, a couple follow up commands to revese any ram hogging i think.  Check it out here.

     

    http://www.macworld.com/article/1053471/sleepmode.html

  • MTBryan Level 1 Level 1 (0 points)

    That's great information (about the sleep mode) but is an entirely different discussion than we have been having recently. We've been talking about the Mac going from Sleep to Hibernate after 4 hours, when powered on. This is specific to the 'autopoweroff' setting.

     

    BTW: I went to the Mac store and looked at that setting on a 13 inch MBP Retina. It was set to the same defaults:

    autopoweroff = 1

    autopoweroffdelay = 14400 (which is 4 hours)

     

    I would think they close the lids at night with the power on and would have the same issue in the morning (Mac is then in hibernate). I was going to ask, but as usual, they were PACKED and I couldn't speak with anyone and didn't want to wait.

  • egsl Level 1 Level 1 (5 points)

    Hi Koreanricequeen,

     

    How is your new mac getting along? Is it running on 10.8.2?

     

    Can you please update share your new mac's pmsetting? I am really interested to know your autopoweroff 0 or 1?  

  • koreanricequeen Level 1 Level 1 (0 points)

    Hello

     

    My new macbook is running on 10.8.2 and it was in hibernation this morning, just like my old one. So getting a new one did not solve the problem (be it software update or manufacturing defect or a combo of the two).

     

    Other than google chrome and skype, I have not added any applications or data, so that mostly rules out any kind of problem from those.

     

    There is an idential macbook in my house running Lion 10.7.5 and it has no problem (same wifi, same power outlet, same place on the desk, same manufacture date, same programs etc). I don't know enough to make any conclusions but I hope this info helps others.

     

    I'm probably going to change my settings as others have so that it has a 24-hour delay before hibernation, and wait for the next update with my fingers crossed that it resolves the problem (which is preferable to an internal design flaw).

     

    The fact that this is not affecting ALL macbooks that were updated to 10.8.2 is what really bugs me. I hope we eventually get to the source of the problem, even though we now have a fairly acceptable patch with fixing the hibernation time out.

  • hockeymagnet Level 1 Level 1 (0 points)

    Thanks for this update. I think we can conclude that this is not a "design flaw". It was ntroduced in the last update and is easily fixed and in fact we do not know that it does not affect all Macbooks that were updated. As far as I can tell this is very wide spread and in fact many people may not even be aware they are affected by it. The biggest problem is that Apple has not appeared to be addressing it either by fixing the problem which they could do easily or getting a release out indicating exactly why they have introduced this new command, what it's purpose is, etc.

  • MTBryan Level 1 Level 1 (0 points)

    regarding hockeymagnet's comment:

    "people may not even be aware they are affected by it"

     

    I only know 3 people personally with new Mac's. 1 of them doesn't use the Mac like I do. He uses it only for personal use. He runs down the battery, plugs it in, continues to use it, goes to bed with it unplugged. He said he may have noticed it hibernating but doesn't remember.

     

    The other two are new to the  Mac world and they just assumed that was normal behavior. Remember folks with older Windows machines actually power down after each use. THE HORROR!

     

    koreanricequeen: Yep, just change one of those settings and all will be well in your Mac world.

     

     

    Cheers all...

  • egsl Level 1 Level 1 (5 points)

    So after setting to sudo pmset -a autopoweroff 0, when Apple updates to 10.8.3, do we need it change back to 1?

  • koreanricequeen Level 1 Level 1 (0 points)

    MYBryant--

     

    Thanks for this info, I'm going to try the method of changing the autopoweroffdelay to 24 hours (86400 seconds) on my new-yet-unchanged macbook.
    Can you tell me the command to put into terminal? I want to be sure I'm typing the correct thing.

     

    Thank you!

  • jzpchen Level 1 Level 1 (0 points)

    It would be nice if Apple documented "autopoweroff" in their man pages. I'm still not too clear on what its purpose is, considering the very similar "standby" option. I've even glanced at pmset's source code, but there's nothing of interest there - everything is handled at a lower level (probably kernel), where source is unavailable.

     

    However, there seems to be a bug regarding hibernatemode: according to the man page, if hibernatemode is set to 0, standby will never occur, but the system seems to do it anyways.

     

    In any case, setting standbydelay and autopoweroffdelay to sufficiently long periods of times does seem to work. It's a useful feature sometimes - but I'd rather not hammer my SSD with 16GB of writes every time I leave for an hour.

     

    This is definitely not a hardware bug though. If you've totally messed up your pmset, reinstalling OS X will restore the original.

  • Summer Storm Pictures Level 1 Level 1 (0 points)

    Day 2, this time with 6-hours of sleep followed by instant wake-up.

     

    The 6 Terminal commands set I assembled together (see my last post) seems to have worked--for me at least. If you decide to apply them, I strongly suggest you apply all 6 of them and in that order.

     

    If day 3 (tonight) brings success, I'll follow-up post one last time.

     

    My only "huh" is from wondering why, with all the brainpower at Apple, how they couldn't come up with this.

  • hockey_magnet Level 1 Level 1 (0 points)

    Summer Storm Pictures:

     

    Can you provide some rationalization/ specific detail as to why you think we should change all 6 of the terminal commands when either simply setting autopower off to 0 or extending the delay time solve the problem. What are the advantages of appying the other commands?

     

    Thanks

  • MTBryan Level 1 Level 1 (0 points)

    koreanricequeen:

    Sure...

     

    First, open Terminal and type in this command:

     

    pmset -g | grep autopoweroff

     

    That command doesn't change anything but shows you the current values, so you'll get this:

     

    autopoweroffdelay14400
    autopoweroff     1

     

    Now, type in this command:

     

    sudo pmset -a autopoweroffdelay 86400

     

    After you type in that command, it will ask for your password. This is the same password you use when you install software. Once you enter the password, it won't give you any confirmation, it just accepts the command.

     

    Now, if you type in that first query again, it should show the new values:

     

    pmset -g | grep autopoweroff

     

    Should now show this:

     

    autopoweroffdelay86400
    autopoweroff     1
  • Summer Storm Pictures Level 1 Level 1 (0 points)

    hockey_magnet:

     

    My “cocktail” of Terminal commands is not for you since you have apparently resolved your issue. It is for those like me whose issue remains unresolved. I am now into day-two of success and hopefully others will likewise be as fortunate.

     

    Also, because there are a lot of other configurations out there, I wanted to make sure that for anyone did want to try my solution, that their settings overall conformed to my own. I wanted a "baseline” from which any success or failure had a point of reference.

     

    Additionally, certain settings, in to be applied correctly, require other settings to be set to certain parameters.

     

    Everything I’ve suggested can be explained far clearer than I could, on an Apple developer page (below) that someone here recommended earlier. This page goes into great detail about the various commands available and what they do.

     

    http://developer.apple.com/library/mac/#documentation/Darwin/Reference/ManPages/ man1/pmset.1.html

     

    Again, if your issue is resolved and your system is working fine, this is not for you.

     

    I'll report in again tomorrow, hopefully to report continued success.

     

    Good luck to everyone.

  • hockey_magnet Level 1 Level 1 (0 points)

    Summer Storm

     

    Thanks, I'm just trying to learn about these settings. That's why I asked - I had already looked at the page you referenced, that's why I asked since I can't understand how setting the delay makes any difference if autopower off is disabled.

     

    Question:

     

    Did your system turn off and hibernate after 10 hours with these settings? This is important to know. Also, did you try just setting autopoweroff to 0 but leaving the other settings alone?

     

    Thanks for helping

Previous 1 5 6 7 8 9 Next