Previous 1 2 3 Next 223 Replies Latest reply: Mar 15, 2015 12:50 PM by mattlesnake
chocobanana Level 1 Level 1 (60 points)

Hi there,

 

Since installing the MacBook Pro/Air 2.0 update, while my computer goes into sleep mode, after a certain amount of time it switches to Hibernation mode automatically.

 

This means that after X amount of hours (could not figure out yet how many exactly), when I wake up the computer, it actually will wake up from an hibernation state, much more slowly.

 

Anyway to restore the old behavior of waking up from sleep only, regardless of how much time has passed?

 

Thanks!


MacBook Pro, OS X Mountain Lion (10.8.2), 2012 15" 2.6Ghz, Anti Glare
  • JohnNY123 Level 1 Level 1 (5 points)

    Hi chocobanana,

     

    I'm having the exact same problem after applying the update.  See my thread about it located here:

     

    https://discussions.apple.com/message/20411674#20411674

     

    The suggestion that I mention in my forum post from Apple Support didn't work, so my next step will be to change the sleep mode using a terminal command.  That process is explained in this article and is very simple to do:

     

    http://macs.about.com/od/usingyourmac/qt/Change-How-Your-Mac-Sleeps-Pick-The-Sle ep-Setting-You-Want-Your-Mac-To-Use.htm

     

    If setting the hibernatemode to '0' doesn't fix the problem, then I'll just sit back and wait for Apple to issue a fix because this seems to be a problem with their latest update and I'm sure we're not the only two people with this problem.  :-(

     

    John

  • JohnNY123 Level 1 Level 1 (5 points)

    Setting hibernatemode to 0 didn't do anything.  the behavior was exactly the same.  So....an Apple fix will probably be needed for this.

  • egsl Level 1 Level 1 (5 points)

    Hi JohNY123,

     

    Have you tried setting autopoweroff to 0?

  • JohnNY123 Level 1 Level 1 (5 points)

    egsl:

     

    I haven't seen anything documenting an autopoweroff command.  Do you have a link I can read that explains it?

     

    John

  • Courcoul Level 6 Level 6 (12,500 points)

    Check the status and health of your battery. Hibernation is an emergency fallback measure for when the sleeping memory gets corrupted, usually due to power loss. If the battery is dying OR the SMC thinks it is dying, hibernation would ensue (hint, hint, reset the SMC).

     

    There used to be a small System Preferences utility called SmartSleep. Unfortunately, the programmer has decided to make money off it in the latest ML-friendly versions. You could try it out in the shareware period.

  • JohnNY123 Level 1 Level 1 (5 points)

    Hi Courcoul...

     

    I can't speak to the original poster of this thread, but my laptop is only three months old....I checked the battery health and it says "Normal" with a Cycle Count of 19.  All looks good there...

     

    I tried resetting the SMC the other day and that didn't fix the problem.

     

    I think this is starting to point to a 10.8.2 update problem since this showed up at the same time as I did the update, the original poster above also started this problem after the update, and there are a slew of sleep-related problems that people are posting after upgrading to 10.8.2.

     

    This is my original thread on this topic if you're interested to read my full story on it.  :-)

     

    https://discussions.apple.com/message/20411674#20411674%2320411674

  • egsl Level 1 Level 1 (5 points)

    I do not know anything about the autopoweroff. One of the user here suggested to used this method and it seems to resolve the problem.

     

    I am hoping for apple to come up with an official update ASAP...

  • chocobanana Level 1 Level 1 (60 points)

    Hi there,

     

    JohnNY123, sorry for not reacting before, I was just doing some testing here and wanted to wait a bit before coming with a conclusion.

     

    First of all, I've been using the SmartSleep app, I don't fancy having to wait for the MacBook to write the hibernation file first before sleeping, but I understand its usefulness when battery is low.

     

    Initially, I thought SmartSleep could be causing the issue but found it hard to believe since all it does is monitor the battery level and switch the sleep mode accordingly. Then, as in the original post, I realized this issue of switching between sleep and hibernation during sleep arised *only* after the last supplemental update. It actually can be useful if your laptop has an SSD and concerve battery life during sleep, but with an HDD it's not as nice when it comes to waking up. Maybe it's related to the PowerNap feature?

     

    Anyway, following the tip of @egsl, I decided to investigate the autopoweroff option. And I came across this: http://apple.stackexchange.com/questions/72889/mountain-lion-aggressively-hibern ates

     

    I suppose that "pmset -g" lists all options that can be tweaked via pmset. So I went on and did:

    sudo pmset -a autopoweroff 0

     

    Voilá, problem solved. Like someone in that stackexchange thread, I find it very unusual for this kind of behavior/option to start happening after an OS minor update. Surely it is a bug for 2012 conventional MacBooks. My 2010 MacBook Pro doesn't behave like so. Indeed, even after the last Mountain Lion update,, "pmset -g" won't even list an option for autopoweroff. On my 2012 MacBook, there's now also a "womp" option, short for "Wake up on magical ethernet package" = PowerNap. My original hypothesis seems to be further correct in that this update "considers" all 2012 latops as MacBook Airs or retina MacBooks, all systems with an SSD, thus there's a bug.

     

    Ok, to summarize, sudo pmset -a autopoweroff 0 seems to fix the issue. Sorry for the long post

     

    Thanks!

  • egsl Level 1 Level 1 (5 points)

    Hi Chocobanana,

     

    Do you think is better to use sudo pmset -c autopoweroff 0 instead of "a" as "c" refers to charger only?

     

    This is so because my hibernation kicks in only when is on charging. Whilst running on batterty it just sleeps throughout.... (another bug?)

     

    Thanks.

  • JohnNY123 Level 1 Level 1 (5 points)

    chocobanana thanks for the great information.  I will read through your detailed linked stackexchange thread when I get home from work.

     

    I'm also going to run a second test tonight to see if I observe the same behavior on battery power while sleeping as I do on AC power while sleeping.  After I see that and know what's going on in both power circumstances then I'll change the setting and hopefully resolve this until a fix comes out from Apple.

     

    It's very clear now that this sleeping/hibernating behavior changed with the 10.8.2 update.  I checked back in my notes and can see that I noted that this started occurring after I did the update.  Before that the machine was working exactly as it did from the day I bought it.

     

    I'll update after I run my next tests...

  • chocobanana Level 1 Level 1 (60 points)

    @egsl I think it's up to you. I used -a because I want to have the same behavior regardless of the power source.

  • egsl Level 1 Level 1 (5 points)

    Hi JohnNY123,

     

    So how was your tests last night? Any new issues to update?

     

    Did your mac go into hibernation on battery while sleeping after a few hours?

  • Summer Storm Pictures Level 1 Level 1 (0 points)

    I have been trying desperately to hammer this syndrome into the head of a senior Apple Technical Advisor, but I get the feeling it either goes in one ear and out the other, or at best, in and out the ear of the engineering staff he communicates with.

     

    I was one of those who for the very first time ever, actually purchased the overpriced AppleCare when I got my MacBook Pro 15-inch "retina" model using the logic that I had a device that was for all intents and purposes, unservicable by me.

     

    From day-one this "pretty box" worked "as advertised" and frankly as anyone would expect a totally RAM-driven expensive device to work--"instant on" among other features. This instant-on feature was perhaps the biggest attraction for me, making me truly mobile.

     

    With this last EFI firmware update, all this came to a crashing end and I might as well have my old machine back, spinning hard drive and all. I now have "instant wait."

     

    I tried the sudo pmset -a autopoweroff 0 suggestion by the way, feeling that after almost two weeks of frustration and getting nowhere with Apple's failure to provide anything more than "voodoo fixes" (turn this off, turn that off, create a new user account etc.). I was hopeful that this would work, but after a night of sleep on battery power, no such luck. I opened my sleeping MBPr and still had to wait for a good almost ten seconds before I could input my password in the dialog box. Thanks for this suggestion. I only wish it actually made a difference. I only wish Apple's own engineers had been as helpful.

     

    Enough said. All I can say is that since I actually purchased AppleCare, I am going to run it into the ground ten-times-over until this issue is fixed. No more mister nice guy. I am going to get what I paid for.

     

    <Edited By Host>

  • chocobanana Level 1 Level 1 (60 points)

    Hi Summer Storm Pictures,

     

    In your case, in addition to the above command, you should try:

     

    sudo pmset -a hibernatemode 0

     

    That will make the computer sleep only, instead of sleep & hibernate which is what you're experiencing and is default on laptops.

     

    The whole reason why I want my computer to sleep only, is precisely because I don't like the time it takes for it to wake up from hibernation and because when I close the lid, I want to put it in a bag immediately without waiting for the hard disk to spin down first.

     

    So, this command a try and hopefully it will sort it out.

Previous 1 2 3 Next