9 Replies Latest reply: Nov 20, 2012 7:21 AM by juliefromstoke-on-trent
juliefromstoke-on-trent Level 1 Level 1

Hi all

I have 3.4.1, purchased through the App Store. The update process tells me that 3.4.3 is available, but the button on the right already shows it as "Installed". Chcking in the software, it still tells me its v3.4.1. Am I missing something obvious?. Downloading 3.4.3 from the Apple site does not allow the update.pkg to be installed, it just refers me to the App Store again....Help!


MacBook Air, OS X Mountain Lion
Reply by Larry West on Nov 16, 2012 6:28 AM Helpful

Which "Update Process" are you talking about? If you purchased Aperture via the Mac App Store, you have to open the Mac App Store and select "Updates" to get the update for Aperture. Software Update (from the Apple Manu) will not do it for you.

Reply by Ernie Stamper on Nov 16, 2012 6:27 AM Helpful

Have you done a Get Info on the app in the Applications folder?

 

You may be better served to delete Aperture from your computer, and simply download afresh.

 

Ernie

All replies

  • Ernie Stamper Level 8 Level 8
    expertise.video
    Video

    Have you done a Get Info on the app in the Applications folder?

     

    You may be better served to delete Aperture from your computer, and simply download afresh.

     

    Ernie

  • Larry West Level 1 Level 1

    Which "Update Process" are you talking about? If you purchased Aperture via the Mac App Store, you have to open the Mac App Store and select "Updates" to get the update for Aperture. Software Update (from the Apple Manu) will not do it for you.

  • William Lloyd Level 7 Level 7

    Delete Aperture from your Applications folder and re-download from the MAS.  This won't affect your pictures or library in any way.

  • juliefromstoke-on-trent Level 1 Level 1

    Thank you all - helpful.

    Get Info told me I have 3.4.1 on my computer - is there anything else I needed to check?

     

    The original App was supplied on my MacBookAir. All updates so far have been through the App Store, but this last (3.4.3) notification simply will not proceed, even though I have the update notification. Strange.

    I am currently loading some image files, and will then follow the delete/reload advice.

    Thank you once again.

     

    NB William, for some reason I was unable to "Like" your response, don't know why.

  • Aye Es Oh Level 2 Level 2

    Just in case, you may just want to put the Aperture application in the trash and not delete it. I'm not sure whether pre-loads nowadays are Mac App Store versions or traditional install-from-disc versions, but if you don't know for sure either, I'd keep the app around in the trash so you aren't stuck if you delete it.

     

    The Mac will treat files in the trash as if they've been deleted, so it shouldn't give you any hassles about reinstalling as it would if you had the app in any other folder on your hard drive.

  • juliefromstoke-on-trent Level 1 Level 1

    Regrettably...sigh

    The update went nearly to the end, then told me that an "error occurred".

    NOW, I can not open Aperture at all. The trashed version, although reinstated, will no longer appear or operate.

    Looks like a trip to the tech. at my nearest Apple centre.

    Thanks all for you help.

  • juliefromstoke-on-trent Level 1 Level 1

    I have restored 3.4.1 from my backup - I think I'll stay there...

    Thank you for your help.

    J

    xx

  • Aye Es Oh Level 2 Level 2

    Julie, did you ever talk to one of the techs at the store? Did they try any troubleshooting, or did they just have you restore from backup?

  • juliefromstoke-on-trent Level 1 Level 1

    Dear All

    I never got to the store techs. in the end.

    Things have moved successfully on. Finally, I took out ALL my computer files onto a backup drive, removing them from the MacBookAir.

    I restored 3.4.1 from my backups, and left it alone for a while.

    After a couple of computer restarts over the next day or so (unrelated to the Aperture issue) I noted that the update for Aperture was no longer available.

    I reopened Aperture, checked the version, and Lo, it has updated to 3.4.3. I'm not sure why or how this happened, but I'm happy that it has.

    Thanks for your suggestions, ALL of which were helpful.