13 Replies Latest reply: Nov 21, 2012 2:21 PM by wilfredfromcastleford
wilfredfromcastleford Level 1 (0 points)

I am trying to order a book from iPhoto but when I go to 'New Book' in the File menu and try to click on any of the options my iMac just freezes.  I get the word  'LOADING'  but the gearwheel is stationary and the beachball of death is spinning merrily.  I have to power down to escape as nothing else works.   Any ideas?


iMac, Mac OS X (10.6.8), iMac 11,1 Intel Core i5. 2.66GHz
  • Old Toad Level 10 (133,280 points)

    Is the book size XXL?  iPhoto has a problem with that size.  If not XXL then it is an issue of creating the PDF file iPhoto uses to upload and print.


    Therefore in either case try the following:


    1 - boot into Safe Mode, Mac OS X: Starting up in Safe Mode.


    2 - open iPhoto and create a PDF file of the book according to this Apple Document: iPhoto '11: Preview a book, card, or calendar before you order or print it.


    3 - preview the book in the PDF file for errors and if not keep the file to compare with the printed book when it arrives.


    4 - order the book while still in Safe Mode.



  • wilfredfromcastleford Level 1 (0 points)

    NO it's not the size, I cant even get that far.  As soon as I click 'New Book' from the file folder and try to choose hardback or soft back it just freezes.   Even happens if I try to choose a calendar or card.   It just won't let me past that first screen.


  • Old Toad Level 10 (133,280 points)

    Oh.  It's not that you can't order a book you can't create a book or calendar in your library.  Therefore try this:  launch iPhoto with the Option key held down and create a new, test library.  Import some photos, try to create a book to check to see if the same problem persists.


    If it doesn't then your current library is damaged.  Therefore, delete the test library, make a temporary, backup copy of your current library if you don't already have one (Control-click on the library and select Duplicate from the contextual menu) and  apply the two fixes below in order as needed:


    Fix #1


    Launch iPhoto with the Command+Option keys held down and rebuild the library.




    Since only one option can be run at a time start with Option #1, followed by #3 and then #4 as needed.


    Fix #2


    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


    1 - download iPhoto Library Manager and launch.


    2 - click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.


    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option.


    4 - In the next  window name the new library and select the location you want it to be placed.


    5 - Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments.  However, books, calendars, cards and slideshows will be lost. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

  • wilfredfromcastleford Level 1 (0 points)

    Sorry O.T. the problem remains and the only way I can get out of that first screen is to power off.  The odd thing is that it is only the iPhoto app that is frozen I can access everything else but I can't log off from the apple logo I have to shut off the power to escape the 'Create Book' screen.  Incidentally where are the libraries stored, I was told last week but I've forgotten, I'm at that age I'm afraid.   I will have delete the test library or I will get even more confused. I can import photos and organise them etc but just cant create the book or calendar or card.   Weird.


  • Old Toad Level 10 (133,280 points)

    Reinstall iPhoto. To do so you'll have to delete the current application and all files with "iPhoto" in the file name with either a .PKG or .BOM extension that reside in the:


    HD/Library/Receipts folder (10.5 and earlier)


    or from the /var/db/receipts/  folder (10.6) .




    or from the /private/var/db/receipts folder (10.7 or later)


    Then install iPhoto from the source it came from originally.

  • wilfredfromcastleford Level 1 (0 points)

    OK, going to try that.  re the original source of iPhoto, it came installed with the machine and I have the iLife 11

    upgrade DVD.  Do I use that one or do I have to get the one  off the original OS disc?  Bear in mind that I have just had the HDD replaced last week and they just installed the original OS X 10.6.3 and I have installed updates to .8.  Not that I know what any of this stuff means I just use the thing.  Sometimes I feel like a moped rider in a Ferrarri.  Feel like just going out and buying an album and sticking the bloody photos in.  (Not really, but it's late.  I do appreciate all your help.



    Message was edited by: wilfredfromcastleford

  • Old Toad Level 10 (133,280 points)

    Use the iLife 11 disc as that will give you the latest version.  If you run into problems with error messages trying to run that disk rest the date on your Mac to areound November, 2010.  Then try running the disk again.  When you're done reset the date back to current.

  • wilfredfromcastleford Level 1 (0 points)

    Hi, O.T.  Do I delet the files with the ext. .plist as well please?


  • Old Toad Level 10 (133,280 points)

    YOu can delete the com.apple.iPhoto.plist file.  It won't hurt and might help.  Be sure to reset the various iPhoto preferences when you relaunch iPhoto the next time.

  • wilfredfromcastleford Level 1 (0 points)

    Well I did all that and re-installed iPhoto 11 from disc, now I can't open iPhoto at all.  The icon has a forbidden sign over it and I get a message saying I can't open it because it may be damaged or incomplete.  Really wish I'd bought the album and some glue.  What if I re-installed iLife which I got when I bought the Mac??  Or would that give me more problems with the other applications.   I reset the date like you said too.  Going to put it back now in case I forget.  then bed, tomorrow the struggle continues.....


  • Old Toad Level 10 (133,280 points)

    You did reinstall it using the iLife 11 disc before, right?  Did you then apply the required updaters, up to Photo 9.3.2?  You can get the updaters from the Apple Downloads webpage.


    It definitely sounds like the application is damaged so try again the iLife disk.

  • wilfredfromcastleford Level 1 (0 points)

    Thanks O.T.  Yes I did reinstall using the iLife 11 disc.  And I did all the updates.  Reset the date as you advised and the result was as in my last post.  I  reinstalled iLife 11 again last night with the same reslts.  It's weird.  I totally lost patience with it last night and simply restored iPhoto from Time Machine.  So now I can at least access and use the application again but of course I am back to square 1 as regards creating a book.  I think I'll just go to Boots or Photobox or some other online photoprinting service.   I love my Apple but sometimes I could chuck it out the bloody window and drag my old steam powered pc out of the garage.  You have taken a great deal of time over my problem O.T. and I thank you and the others who have tried to resolve my problem. 


  • wilfredfromcastleford Level 1 (0 points)

    Hi Folks just an update on this problem, sorry it's for the delay but installed Mountain Lion and been getting up to speed on it.  Concerning the problem with creating a book,  eventually contacted Apple support and after 1-1/2 hours with a tech trying virtually all the things you guys had told me and a few others I was referred to a senior Tech Manager who was also baffled but after I gave permission for them to look at my screen to see for themselves what was happening he eventually sorted it out.  It took about another hour and a half but they were paying for that.  Don't ask me what he did 'cos there were so many things that he whizzed me through.  It was as you guys suspected a library fault but it was fairly well buried.  I wish I could tell you exactly how it was resolved so you could add it to your expertise but I can't - sorry.  Anyway lots of thanks and respect to all of you who tried to help and gave of your time and knowledge especially O.T. out there in sunny California.  Till the next time,

    Cheers from a very wet Yorkshire.