5 Replies Latest reply: Nov 16, 2012 3:20 PM by Niel
Josalyne Level 1 Level 1 (0 points)

So I'm in a dillema, I just purchased the iphone 5 and I can't connect to itunes because I do not have version 10.7, I try to install that but it says that I need os x 10.6.8 or later and I currently have 10.5.8.  I did a software update but it tells me that there aren't any updates!? What gives?...


MacBook Pro, Mac OS X (10.5.8)