3 Replies Latest reply: Nov 19, 2012 1:32 AM by Shane Ross
vigilare Level 1 Level 1 (0 points)

Does anyone know why I can't install FCP5 on Lion?  It is a universal app and should install correctly.

 

I get the error "You can't open the application Final Cut Studio.mpkg because PowerPC applications are no longer supported".

 

This error happens with Final Cut Studio and DVD Studio Pro but Soundtrack Pro does install and work correctly.

 

Again, they are all marked as Universal apps, so not having Rosetta anymore shouldn't matter.

 

Ideas?

 

Jason


Final Cut Studio 5, Mac OS X (10.7.5)
  • Shane Ross Level 8 Level 8 (42,460 points)

    Ah...but having Rosetta still does matter with that older version.  FCP 5 and 6, although they were cross platform, the INSTALLERS weren't.  Yeah, odd and stupid.  But the installers were PowerPC and required Rosetta.  The only FCP version that had a native installer was FCP 7.  Oh, and now FCX. 

     

    Sorry, you can't install FCP 5 on Lion or Mountain Lion.

  • Michael Grenadier Level 7 Level 7 (20,335 points)

    uh, can't you do a custom install of rosetta from a snowleopard install disk?  I've done that so I could install fcp6 on new machines without a problem.

     

    And it's gotta be the universal version of fcp5.  Wasn't that 5.1 I think.

  • Shane Ross Level 8 Level 8 (42,460 points)

    Right...sorry, you can't install Rosetta on MOUNTAIN Lion...but you can install onto Lion. 

     

    Also true that you need FCP 5.1.  FCP 5.0 is PowerPC...5.1 is the Unversal.