3 Replies Latest reply: Nov 3, 2013 11:45 PM by tesme33
angryiphoneuser Level 1 Level 1 (0 points)

I have been trying to get Roundcube / Managesieve to work on my 10.8.2. ML server.  Managesieve has been unable to connect to the Sieve server and after lots of debugging I do not think Sieve is installed / working.

 

I cannot telnet Sieve on port 2000 or 4190 - just getting 'connection refused'.  Is the Dovecot Sieve plugin still in MLServer and if so any idea where I start the fault finding?

  • 1. Re: Sieve not responding
    tesme33 Level 1 Level 1 (10 points)

    Hi

     

    check with doveconf if the service is configured.

     

    Sample:

     

    sh-3.2# doveconf

    # 2.0.19apple1: /Library/Server/Mail/Config/dovecot/dovecot.conf

    # OS: Darwin 12.3.0 x86_64  hfs

    aps_topic = com.apple.mail.XServer.d85b9a88-be8a-40d8-ac4b-9dc1bac167a5

    ...

    service managesieve-login {

      chroot = login

      client_limit = 0

      drop_priv_before_exec = no

      executable = managesieve-login

      extra_groups =

      group =

      idle_kill = 0

      inet_listener sieve {

        address =

        port = 4190

        ssl = no

      }

    ...

     

     

    Config is at:

    /Library/Server/Mail/Config/dovecot/conf.d/20-managesieve.conf

     

    ---- 20-managesieve.conf ---

    ##

    ## ManageSieve specific settings

    ##

     

    # Service definitions

     

    service managesieve-login {

      inet_listener sieve {

        port = 4190

      }

     

    --------------------------

     

    If you didnt change anything.

    Location can also be found based on the output of your doveconf command.

     

    sh-3.2# doveconf

    # 2.0.19apple1: /Library/Server/Mail/Config/dovecot/ <<-- indication of conf.d directory

     

    Check config there.

     

    Hope this helps.

  • 2. Re: Sieve not responding
    Matt Domenici Level 1 Level 1 (110 points)

    Try doing this:

     

    sudo serveradmin settings mail:imap:enable_sieve

     

    If you get a "no" you found your problem.

     

    Try this:

     

    sudo serveradmin settings mail:imap:enable_sieve = yes

     

    Then use the network utility to be sure it's listening on port 4190.

  • 3. Re: Sieve not responding
    tesme33 Level 1 Level 1 (10 points)

    Hi

    after upgrading to 10.9 you have to enable sieve again !

     

    e.g.: sudo serveradmin settings mail:imap:enable_sieve = yes

     

    Yours