4 Replies Latest reply: Nov 17, 2012 6:07 PM by ChrisJ4203
danaalene5 Level 1 Level 1 (0 points)

i have iphone 4 software version 4.2.5 (i know, i know...) when i go to iTunes store on my mac and click update it just tells me that this version of iTunes is up to date...??? i've looked at the apple help several times and can't find my answer. help!


iPhone 4, iOS 4.3.2
  • ChrisJ4203 Level 8 Level 8 (36,740 points)

    You first need to make sure you have the latest version of iTunes, which is 10.7. iTunes 10.7 also requires OSX 10.6.8 or higher. Once you meet those requirements, you should be able to update the iOS on the phone to iOS 6.0.1.

  • danaalene5 Level 1 Level 1 (0 points)

    Thanks - is there any other way?  i pretty much use my iPhone for everything and don't have internet connection on my iMac at home  - there has to be more people with this problem... why do they make it so hard??!

  • danaalene5 Level 1 Level 1 (0 points)

    Also, I would be happy just upgrading to iOS5 - but i went through the restore and update process which i finally figured out, and after 30 minutes i got an error saying that thie iPhone isn't eligible.

  • ChrisJ4203 Level 8 Level 8 (36,740 points)

    The only iOS you can get is the latest. If you have the iPhone 4, that is iOS 6.0.1. However, the other requirements apply if you want to do that. It really isn't hard, part of it has to do with the fact you haven't updated the phone in a while. You could have tried the over the air (OTA) update had you been on iOS5, but until then, you have to connect to iTunes. To connect the iPhone 4 to iTunes and update to iOS6, you need to comply iwth the requirements I listed earlier.