Skip navigation

how to update mac os x 10.4.11 to 10.5

79477 Views 8 Replies Latest reply: Sep 27, 2013 1:49 AM by a brody RSS
SherwinLiu Level 1 Level 1 (0 points)
Currently Being Moderated
Nov 17, 2012 9:10 PM

how to update my mac system from mac os x10.4.11 to mac os 10.5? my mac has intel cpu mbp

MacBook Pro, Mac OS X (10.4.11)
  • Kappy Level 10 Level 10 (221,065 points)
    Currently Being Moderated
    Nov 17, 2012 9:12 PM (in response to SherwinLiu)

    Upgrading to Snow Leopard, Lion, or Mountain Lion

     

    Upgrading to Snow Leopard

     

    You can purchase Snow Leopard by contacting Customer Service: Contacting Apple for support and service - this includes international calling numbers. The price is $19.99 plus tax. You will receive physical media - DVD - by mail.

     

    Third-party sources for Snow Leopard are:

     

    Snow Leopard from Amazon.com

    Snow Leopard from eBay

     

    After you install Snow Leopard you will have to download and install the Mac OS X 10.6.8 Update Combo v1.1 to update Snow Leopard to 10.6.8 and give you access to the App Store.

     

    Before upgrading check that you computer meets the minimum requirements:

     

    Snow Leopard General requirements

     

      1. Mac computer with an Intel processor

      2. 1GB of memory

      3. 5GB of available disk space

      4. DVD drive for installation

      5. Some features require a compatible Internet service provider; fees may

          apply.

      6. Some features require Apple’s MobileMe service; fees and terms apply.

     

    Upgrading to Lion

     

    First, you need to upgrade to Snow Leopard 10.6.8 as stated above.

     

    You can purchase Lion by contacting Customer Service: Contacting Apple for support and service - this includes international calling numbers. The cost is $19.99 (as it was before) plus tax.  It's a download. You will get an email containing a redemption code that you then use at the Mac App Store to download Lion. Save a copy of that installer to your Downloads folder because the installer deletes itself at the end of the installation.

     

    Before upgrading check that you computer meets the minimum requirements:

     

    Lion System Requirements

      1. Mac computer with an Intel Core 2 Duo, Core i3, Core i5, Core i7, or

          Xeon processor

      2. 2GB of memory

      3. OS X v10.6.6 or later (v10.6.8 recommended)

      4. 7GB of available space

      5. Some features require an Apple ID; terms apply.

     

    Upgrading to Mountain Lion

     

    Be sure your computer meets the minimum requirements:

     

    Apple - OS X Mountain Lion - Read the technical specifications.

     

    Macs that can be upgraded to OS X Mountain Lion

     

      1. iMac (Mid 2007 or newer)

      2. MacBook (Late 2008 Aluminum, or Early 2009 or newer)

      3. MacBook Pro (Mid/Late 2007 or newer)

      4. MacBook Air (Late 2008 or newer)

      5. Mac mini (Early 2009 or newer)

      6. Mac Pro (Early 2008 or newer)

      7. Xserve (Early 2009)

     

    Are my applications compatible?

     

    See App Compatibility Table - RoaringApps - App compatibility and feature support for OS X & iOS.

     

    Am I eligible for the free upgrade?

     

    See Apple - Free OS X Mountain Lion upgrade Program.

     

    For a complete How-To introduction from Apple see Apple - Upgrade your Mac to OS X Mountain Lion.

  • Texas Mac Man Level 8 Level 8 (44,245 points)
    Currently Being Moderated
    Nov 20, 2012 3:05 PM (in response to SherwinLiu)

    Mac OS X 10.5 Leopard installation system requirements

    http://support.apple.com/kb/TA24950

     

    Look on eBay or Google the installer part numbers to possibly find at an on-line store. Here's what to look for:

     

    MB427Z/A  Leopard 10.5.1 install DVD

    MB576Z/A  Leopard 10.5.4 install DVD

    MB021Z/A  Leopard 10.5.6 install DVD (single user)

    MB022Z/A  Leopard 10.5.6 install DVD (5-user family pack)

     

    Installing Mac OS X 10.5 Leopard

    http://support.apple.com/kb/HT1544

     

    Mac OS X 10.5 Leopard Installation and Setup Guide

    http://manuals.info.apple.com/en/leopard_install-setup.pdf

     

    After you install the base 10.5, download & install the 10.5.8 combo update at http://support.apple.com/downloads/Mac_OS_X_10_5_8_Combo_Update

     

    The DVD should look like this

    leopard.jpg

     

    Caution - Leopard does not support classic mode. So, if you currently open OS 9 apps in classic mode, you won't be able to do this if you upgrade to Leopard.

     

     Cheers, Tom

  • Irontri Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 26, 2013 7:07 PM (in response to Texas Mac Man)

    I would like to know how I can update my older PowerBook G4 since all the information that I seem to run across is for Intel chips.  Here is the configuration for my computer.

     

    Machine Name:          PowerBook G4 15"

      Machine Model:          PowerBook5,8

      CPU Type:          PowerPC G4 (1.5)

      Number Of CPUs:          1

      CPU Speed:          1.67 GHz

      L2 Cache (per CPU):          512 KB

      Memory:          1 GB

      Bus Speed:          167 MHz

      Boot ROM Version:          4.9.6f0

      Serial Number:          W8******SWZ

      Sudden Motion Sensor:

      State:          Enabled

     

     

    System Software Overview:

     

      System Version:          Mac OS X 10.4.11 (8S165)

      Kernel Version:          Darwin 8.11.0

      Boot Volume:          Macintosh HD

     

    Any help will be greatly appreciated

     

    <Edited by Host>

  • Kappy Level 10 Level 10 (221,065 points)
    Currently Being Moderated
    Jan 9, 2013 2:13 PM (in response to Irontri)

    Leopard System requirements

     

    You must have a Macintosh computer with:

     

    • an Intel processor or a PowerPC G4 (867 MHz or faster) or G5 processor
    • a DVD drive >built-in FireWire
    • at least 512 MB of RAM (additional RAM is recommended for development purposes)
    • a built-in display or a display connected to an Apple-supplied video card supported by your computer
    • at least 9 GB of disk space available, or 12 GB of disk space if you install the developer tools

     

    10.5.8 is as far as you can go in a G4.

  • yung_reezy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 16, 2013 3:33 AM (in response to SherwinLiu)

    Hi do u know where i can buy a laptop battery?

    My battery is from :Mac os x 10.4.11

    Or do u know any1 that knows where to buy them from?

    And is there a hardrive that i can put in to make my memory bigger?

  • a brody Level 9 Level 9 (62,060 points)
    Currently Being Moderated
    Feb 17, 2013 9:21 AM (in response to yung_reezy)

    http://www.macsales.com/ frequently has batteries for the computer in question.  Go to Apple menu -> About This Mac -> More Info, and look for the name of the machine followed by x,y.    MacBook 4,1 is an example of what you are looking for.  Knowing that, you can then figure out the age of the computer and the series it is according to Apple. 

     

    http://www.everymac.com/systems/by_capability/macs-by-machine-model-machine-id.h tml

    Is an excellent guide by Machine ID that will tell you which model and vintage you actually have, before you go and buy the battery.

    Memory on computers come in primarily two different sources.  Hard drives, and Physical RAM.     Hard drives on Mac notebooks labelled MacBook all support at minimum a 2.5" SATA 9.5mm drive with 1.5 Gbps path.   17" notebooks were the first to support the 12.5mm drives.    Once Apple shifted to the unibody model, they supported 12.5" in all notebooks.   But since the Unibody didn't come out until 2008, and 10.5 was released in 2007, only the 17" model supports the 12.5" drives.   Getting an older hard drive that supports the 1.5 Gbps is going to be more difficult at this time, but http://www.macsales.com/ should be able to advise you correctly if you speak with them.  Physical RAM, once you know your vintage, you can get either from http://www.macsales.com/ or from other sources, but be sure they specify your vintage when you buy it, as my FAQ* explains:

    http://www.macmaps.com/badram.html

    OS X Mountain Lion, * Links may give me compensation
  • itsmemushel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 26, 2013 7:04 PM (in response to Kappy)

    Do you know if they sell a version that you can download? My I-mac's dvd/cd player no longer works

  • a brody Level 9 Level 9 (62,060 points)
    Currently Being Moderated
    Sep 27, 2013 1:49 AM (in response to itsmemushel)

    Nope.  But you can buy an external DVD based optical drive from the vendor I already mentioned on this thread, http://www.macsales.com/ or an internal optical drive kit to replace the one that is damaged.   Also If you take the machine into an authorized service center they can tell you if there is a PRAM battery which may be more than 4 years old is dead enough to cause the optical drive to malfunction, and have that PRAM battery replaced.  Mind you depending on the model, a new battery may cost more than the optical drive since it can be just a plain capacitor sitting on the motherboard.    So get an estimate from them first how much it would to replace. PRAM batteries are separate from the batteries that let the notebook machine run off the mains.  

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.