4 Replies Latest reply: May 17, 2013 12:58 PM by Bob Maguire
tman07042 Level 1 Level 1 (0 points)

When I try syncing my iPhone 4 to my brand new macbook pro, the sync aborts at step 4.  All of my apps and music are updated in itunes and ready to sync, but the process just quits after about 30 seconds (at the start of step 4).


How can I sync my apps and music without losing any data?

iPhone 4, iOS 6.0.1
  • tman07042 Level 1 Level 1 (0 points)

    To clarify- the sync quits during the "determining apps to sync" step.  Not sure what to do!  Thanks for any suggestions anyone has...

  • RMUNSON01 Level 1 Level 1 (0 points)

    I have the same problem (iPhone 4, step 4, determining apps to sync...) except mine is on a Windows 7 PC, not a macbook.

  • JamesOreos Level 1 Level 1 (0 points)

    Hey guys, I found a solution. I had the same problem, the sync will say "Determining apps to sync" in step 4 - 7 then suddenly just quits. So I did some research, apparently a lot of people have this problem, but everyone were just trying on their own PC, so I decided to try on my other laptop. My iPod synced perfectly with the other laptop so I knew it was the PC that was the problem, not my iPod. So basically it's just iTunes. I followed these steps to completely remove and reinstall iTunes on my PC and Viola! It syncs perfectly again!


    Here's the link to the steps: http://www.imobie.com/support/completely-remove-and-reinstall-itunes.ht


    Note: Before I did this, BeBuoi said to remove all the apps and resync, but that didn't work for me. So when I did all these steps, I had no apps in my iPod.



  • Bob Maguire Level 1 Level 1 (65 points)

    I had a similar scenario. I had need to add an app to my iPhone 4S (which is tied to my iTunes library at home on my Mac) on my PC at work. I still wanted to keep everything on my phone, so I authorized my work PC to the same iTunes account I use at home. I add the app through iTunes, clicked "Install", clicked "Apply" and it gets to step 3, then just stops, and nothing's synced.


    I tried uninstalling iTunes and re-installing, de-authorizing and re-authorizing, and nothing worked, still stopped after step 3.


    What finally fixed it was me remembering I had an app already on the phone from a second iTunes account I have, which was not authorized on the work PC. After I authorized that account for the machine as well, the sync worked perfectly.


    Seems like iTunes asks to authorize the first account it finds, but if you have multiple accounts tied to the device, it fails silently when it detects the rest.


    In retrospect, it might've also worked if I had deleted the app in question instead of doing the second authorization, but that's a complete guess.