0 Replies Latest reply: Nov 19, 2012 7:55 AM by GioVle
GioVle Level 1 Level 1 (0 points)



I'm currently working with a Mac OS X 10.6.8 Server with 2x1TB drive installed in RAID configuration (/Volumes/LTRK) and 1x2TB installed as a regular volume (/Volumes/LTRK2/). For both volumes I could set all permissions perfectly, but recently, I cannot change the permissions on the 2TB volume. I have the following current permissions:



  • Group of regular division members (read + all descendants)
  • Group of ICT co-workers (read/write + all descendants)
  • Administrators (read/write + all descendants)
  • Everyone (read + all descendants)


  • The admin user account (read/write + this folder)
  • The 'staff' group which is automatically there (read/write + this folder)
  • Others (read + this folder)


If I compare to the drive where I can change the permissions and where everything works correctly (the RAID config), the only difference is that the 'Everyone' group permissions are not set to be inherited for the working drive (so only on the volume level). I wanted to check whether this was the source of my problems and tried to change the permissions of the 'Everyone' group. However, as soon as I click Save in Server Admin, it automatically reverts to all descendants.


The results of the failure to reset the permissions, leads to the fact that I don't have write access anymore with the admin user accound (I guess due to counteracting permissions). I also tried to delete all permissions from the volume with "chmod -R -N /Volumes/LTRK2" but this gives me a list of every file on that volume, with the error message: "chmod: Filed to clear ACL on file filename: Invalid argument"


Does anyone have any suggestions on how to solve this issue?


Kind regards

Mac OS X Server, Mac OS X (10.6.8)