5 Replies Latest reply: Jan 29, 2013 5:27 PM by glendamelendez
Barhutch Level 1 Level 1 (0 points)

I have a ipod touch3 and some of the apps will not install, they tell me "update Required this app requ ires  iOS4.3" how do I update.


iPod touch, iOS 4.2