Previous 1 2 Next 26 Replies Latest reply: Dec 4, 2012 3:07 PM by drdocument
rogsmith34 Level 1 (0 points)

I have Mountain Lion and an external HD via USB for Time Machine. I went to restore a folder that I had deleted and was given the message "you do not have permission to access..." I also noticed that my backup changed names (from HD TO HD(2)). Can anyone help me? All of my permissions are set to read & write. I cannot get the verify "disk permissions" on the external to highlight in disk utility.

Thank you

iMac, Mac OS X (10.7), 500GB, 4GB, iPod Classic, Touch
  • Linc Davis Level 10 (184,470 points)

    You do not have permission to access what?

  • rogsmith34 Level 1 (0 points)

    Anthing I try to move : "the operation cannot be completed because you do not have permission to access "(file name)" anything...folder, file gets the same result.


  • Linc Davis Level 10 (184,470 points)

    This procedure will unlock all your user files (not system files) and reset their ownership and access-control lists to the default. If you've set special values for those attributes on any of your files, they will be reverted. In that case, either stop here, or be prepared to recreate the settings if necessary. If none of this is meaningful to you, you don't need to worry about it.


    Step 1

    Launch the Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Drag or copy — do not type — the following line into the Terminal window, then press return:

    sudo chflags -R nouchg,nouappnd ~ $TMPDIR.. ; sudo chown -R $UID:20 ~ $_ ; chmod -R -N ~ $_ 2> /dev/null

    Be sure to select the whole line by triple-clicking anywhere in it. You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up. You don't need to post the warning. If you don’t have a login password, you’ll need to set one before you can run the command.

    The command will take a noticeable amount of time to run. Wait for a new line ending in a dollar sign (“$”) to appear, then quit Terminal.

    Step 2


    Boot into Recovery by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

    When the OS X Utilities screen appears, select Utilities Terminal from the menu bar. A text window opens.

    In the Terminal window, type this:


    That's one word with no spaces. Then press return. A Reset Password window opens. You’re not going to reset a password.

    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.

    Select your username from the menu labeled Select the user account if not already selected.

    Under Reset Home Directory Permissions and ACLs, click the Reset button.

    Select  Restart from the menu bar.

  • rogsmith34 Level 1 (0 points)

    Followed all instructions. Getting the same result. Same message. Did not have an option of selecting the external HD when resetting permissions. Is there a way to do a similar reset on this?

    Thank you for the assist!

  • drdocument Level 4 (3,010 points)

    Were you attempting to restore from within the Time Machine interface? Or by simply going to the TM backup volume in Finder?


    If you want to restore something it starts by clicking Time Machine icon in the Dock.

  • Linc Davis Level 10 (184,470 points)

    You can't repair the permissions of a Time Machine volume in Disk Utility. That's only for boot volumes.


    The easiest way for you to overcome this problem is to use Migration Assistant to copy the data to a new user account. Once you've done that, you can log in to the account, fix the permissions (if necessary) as above, and then copy the files you need to your existing account. After that, delete the new account.


    How to use Migration Assistant to transfer files from a Time Machine backup

    Using Migration Assistant on Mountain Lion or Lion

  • rogsmith34 Level 1 (0 points)

    I have tried both ways...same result. Any idea why I can't repair permissions through disk utility on the external disk? Options are not highlighted.


  • j@nsen Level 1 (0 points)

    Hello,  I just came across a similar problem.  Since I upgraded to Mountain Lion (by wiping my HDD clean and starting afresh) I have not been able to restore the Time Machine for my UserID only.  The rest of family work doesn't have this problem.


    Anyway, I fixed it quite easily.  In Finder I selected Time Machine, and tunnel down the directories, in my case through:

    Backups.backupdb\iMac\2012-10-28-080640\Mactintosh HD\Users\Dad (that's me).  All the directories under Dad show the no permission icon.  In Finder I then go to File - Get Info, where I don't my name under Permissions, although I do see a "Fetching..." which I assume is the OS trying to find me.  Also intersesting is that "everyone" is listed as Read only, but apparently that doesn't include me.  Regardless, I just added myself back to the Permissions list with "Read only" making sure I also apply those permissions to all the enclosed items. 


    In my case I do have to click the lock two times before it will add my name, but hey, it works.


    I hope this solves your problem too.



  • Linc Davis Level 10 (184,470 points)

    Surprisingly, that works.

  • rogsmith34 Level 1 (0 points)

    Thanks, I will try that... if I can recover my data! It appears my drive corrupted in the last few days. It says I have 307GB of 1TB free, but Time Machine only shows 2 days' backups... Corrupted a few months ago too and I wiped it clean. "Anyone have that 800 number for Carbonite??" (a takeoff of a line from Top Gun)

    Thanks for the advice

  • drdocument Level 4 (3,010 points)

    It's helpful to remember that when a drive is reformatted (such as in "clean install") a new UUID (ID number) applied, and because Time Machine uses UUID to identify the drive, the prior backup files would not be identifiable as being from that drive.


    Essentially, as far as TM is concerned, the previous drive is gone.


    The best way to retrieve files from a TM backup after an "clean install" is Control-Click on the TM icon in the Dock and choose "Browse other Time Machine disks."


    I don't know why some people think it important to "clean install" when updating OS. If the drive verifies without error it would seem ro do nothing but create more inconvenience.

  • rogsmith34 Level 1 (0 points)

    Thanks. So how can I access the 600+GB that show on the disk? With TM turned off. I have no idea how this happened; I have done nothing to change this disk.


  • drdocument Level 4 (3,010 points)

    Just to recap, you have your startup drive (HD), and your external TM drive; is that external where the 600+GB is located which you want to access? You want to access data from the earlier TM backup?


    Are you using the same user name for your ML system as before? If not, do you know the previous user name and password?


    You still have free space on your external drive, right? And you want to use it for TM backup?

    It sounds like you have already started using it for backup. Right?


    Go ahead and turn on TM.

    Then Control-click the TM icon in the Dock and choose "Browse Other Backup Disks" and choose the backup from the prior system. You should then be able to resetore from there. Choose a particular folder to restore and see if it works.


    Let us know.

  • rogsmith34 Level 1 (0 points)

    Thanks for trying. All of your details are correct. I am the only user of this machine, so yes, TM is under my acct. When I control click the TM icon, I get one option, the disk that is mounted. I cannot see the other backups totalling 693 GB.

Previous 1 2 Next